Main Menu
Advertisement
Affiliates
Advertisement
Newest Members
brandon colopy, John and Misti, saeed, 1217, Sandshark232000
108201 Registered Users
Top Posters
TexDawg 88856
hopalong 78895
Pilothawk 76437
John175® 67806
JDavis7873® 67390
FattyMcButterpants 60879
Derek 🐝 60447
Tritonman 58048
LoneStarSon® 54509
SkeeterRonnie 53404
facebook
Forum Stats
108201 Members
60 Forums
863513 Topics
12301687 Posts

Max Online: 36273 @ 01/23/13 02:34 PM
Topic Options
#12659477 - 03/05/18 02:17 PM 90hp Mercury outboard issue
Kyle_N07 Offline
Angler

Registered: 03/30/07
Posts: 456
Loc: Lake Granbury
I am having a problem with the Throttle Lever. I can start the motor in neutral and shift to reverse or forward...but when trying to get it back into neutral lever is very stiff. It seems like its not clicking back into neutral and motor is running faster than ideal speed. any help or ideas is appreciated.

Top
#12659757 - 03/05/18 04:57 PM Re: 90hp Mercury outboard issue [Re: Kyle_N07]
EastBay Boats Offline
Outdoorsman

Registered: 12/05/17
Posts: 30
Loc: Texas, 77414
Without actually looking at it l can't be 100 percent sure, but your describing your control cables need to be replaced, use Hi-Lux cables you will get 20 years of service out of them
_________________________
979 323 9087/Howard

Top
#12660415 - 03/06/18 07:56 AM Re: 90hp Mercury outboard issue [Re: Kyle_N07]
Kyle_N07 Offline
Angler

Registered: 03/30/07
Posts: 456
Loc: Lake Granbury
Thank for the help...will try that first

Top
#12664877 - 03/09/18 07:49 AM Re: 90hp Mercury outboard issue [Re: Kyle_N07]
boatwhisperer Offline
Extreme Angler

Registered: 09/25/10
Posts: 1502
Loc: hurst, tx
adjust the throttle cable to take the slack out of the cable
_________________________
boatwhisperer

Top



© 1998-2018 OUTDOOR SITES NETWORK all rights reserved USA and Worldwide