Main Menu
Advertisement
Affiliates
Advertisement
Newest Members
Jkaggie, crobalo, Ecwfishing, Keithorr, wclopton
109062 Registered Users
Top Posters
TexDawg 89810
hopalong 78895
Pilothawk 77210
John175® 69342
JDavis7873® 67392
Derek 🐝 61483
FattyMcButterpants 60906
Tritonman 58331
LoneStarSon® 54755
Mark Perry 54064
facebook
Forum Stats
109062 Members
60 Forums
781399 Topics
10105795 Posts

Max Online: 36273 @ 01/23/13 02:34 PM
Topic Options
#12646635 - 02/25/18 06:31 PM question on mew lowrance eilte 5 ti install
Madatu Offline
Outdoorsman

Registered: 02/21/17
Posts: 180
Loc: Texas
everything was normal for an hour or so but then the unit just started flickering fast and turning off. i left it off for a hour or so and turned it back on. it was fine then. i know this isnt not normal. anyone have any suggestions of what to check. it is on my crank battery as well as my humminbird unit. the humminbird unit ran fine. it is not connected to my trolling motor batteries.
_________________________
Mike Warren

Top
#12646851 - 02/25/18 08:10 PM Re: question on mew lowrance eilte 5 ti install [Re: Madatu]
Capt Craig Online   content
Extreme Angler

Registered: 08/25/09
Posts: 1628
Loc: Richland-Chambers
Could be a loose or poorly connected power or ground. Retrace them.
_________________________
Capt. Craig Copeland
Licensed by the US Coast Guard

2019 Nautic Star 215 XTS Shallow Bay Boat
Humminbird HELIX 12 CHIRP MEGA SI GPS G2N
Nautic Star Boats Pro Staff (nauticstarboats.com)
Redneck Fish'n Jigs Pro Staff (redneckfishn.com)

Top
#12648223 - 02/26/18 05:22 PM Re: question on mew lowrance eilte 5 ti install [Re: Madatu]
Madatu Offline
Outdoorsman

Registered: 02/21/17
Posts: 180
Loc: Texas
well i went back to the lake today and had no issue with the unit. all i did is wiggle all the connections before going out on the water.
_________________________
Mike Warren

Top



© 1998-2018 OUTDOOR SITES NETWORK all rights reserved USA and Worldwide