Main Menu
Advertisement
Affiliates
Advertisement
Newest Members
TurnbowKnows, Scotmcm, Dukboy, donbo, fay allen
107079 Registered Users
Top Posters
TexDawg 87852
hopalong 78878
Pilothawk 76045
JDavis7873® 67386
John175® 66415
FattyMcButterpants 60846
Derek 🐝 59552
Tritonman 57891
LoneStarSon® 54162
SkeeterRonnie 53236
facebook
Forum Stats
107079 Members
60 Forums
820614 Topics
10374261 Posts

Max Online: 36273 @ 01/23/13 02:34 PM
Topic Options
#12597945 - 01/27/18 01:21 PM Humminbird Issues
BCBassCat Online   content
Angler

Registered: 04/10/17
Posts: 439
Loc: Sanger TX
Ok so I bought a H9 SI GPS and a H7 DI back in 2016. I used my DI unit for about 6 months before it started fading out and finally crapped out outside the warranty time so I just put it up. Said I'd fix it later no big deal. My H9 was good last November, I had to replace all my batteries so I shut it down. Just got everything put back together after some new batteries and some much needed TLC. I'm getting set to head out for a few hours and put my H9 on and it's locked up on the Humminbird screen!! Are there any fixes for this or will I have t send it in? Frickin electronics...

Top
#12598038 - 01/27/18 03:21 PM Re: Humminbird Issues [Re: BCBassCat]
44 Diesel Online   content
TFF Celebrity

Registered: 12/25/12
Posts: 5034
Loc: Burleson,TX
if you have any map cards in it, remove them. Since you replaced the batteries double check and make sure all power connections are good and tight. Was there any rewiring done to the boat? How is the unit wired for power, to the battery directly or accessory fuse panel?


Edited by 44 Diesel (01/27/18 03:24 PM)

Top
#12598178 - 01/27/18 05:43 PM Re: Humminbird Issues [Re: BCBassCat]
BCBassCat Online   content
Angler

Registered: 04/10/17
Posts: 439
Loc: Sanger TX
Yes there is a zero lines card in it. I took it out and played around with the wire harnesses and got it to come on. While out on the water I put the card back in and it locked up. Killed master power and brought it back up and literally hit it couple times (not hard) and it came back on. I know there's an inline fuse in the battery compartment. Not sure if it goes to the fuse block under the console. No rewiring and everything was tight.

Top
#12598240 - 01/27/18 06:31 PM Re: Humminbird Issues [Re: BCBassCat]
44 Diesel Online   content
TFF Celebrity

Registered: 12/25/12
Posts: 5034
Loc: Burleson,TX
I would recommend wiring straight to the battery with at least 14 ga wire straight to the battery with a fuse at the battery. Accessory fuse panels and the boats wiring harness are gonna give you issues cause they are usually not wired with the correct size wire from factory.

Top
#12599162 - 01/28/18 03:45 PM Re: Humminbird Issues [Re: BCBassCat]
BCBassCat Online   content
Angler

Registered: 04/10/17
Posts: 439
Loc: Sanger TX
I've gone out there and done some investigating and I will have to double check where it comes in at at the console. But it looks like 14 awg to me. The unit will come on and as soon as I plug the card in it locks up. Why would it have worked for a year and half and start this now?

Top
#12599381 - 01/28/18 06:25 PM Re: Humminbird Issues [Re: BCBassCat]
44 Diesel Online   content
TFF Celebrity

Registered: 12/25/12
Posts: 5034
Loc: Burleson,TX
Have you added any new waypoints since your last use? I would try backing up all the waypoints to an SD card. Then "format nav directories". This will delete all your waypoints and nav data so you wanna make sure you have emball backed up. Then try putting in your card again.


Edited by 44 Diesel (01/28/18 06:26 PM)

Top



© 1998-2017 OUTDOOR SITES NETWORK all rights reserved USA and Worldwide