Main Menu
Advertisement
Affiliates
Advertisement
Newest Members
HughGass, Hockley, jl44, firemom2bay, Clynn5
108006 Registered Users
Top Posters
TexDawg 88614
hopalong 78895
Pilothawk 76392
John175® 67565
JDavis7873® 67390
FattyMcButterpants 60868
Derek 🐝 60254
Tritonman 57991
LoneStarSon® 54396
SkeeterRonnie 53366
facebook
Forum Stats
108006 Members
60 Forums
811078 Topics
10272342 Posts

Max Online: 36273 @ 01/23/13 02:34 PM
Topic Options
#12501006 - 11/12/17 09:07 AM Motorguide XI5 Problems
Tx Tree Grower Offline
Pro Angler

Registered: 09/17/08
Posts: 822
Loc: Palestine, TX
Multiple times now I have had issues with my XI5. I operate it with a hand remote. It started with the turning being sluggish. It would either not move or turn very slow. It did it equally bad on both turn directions. I also had some issues with the prop on off command but nothing like the turn. I have had this unit since July. I replaced the remote battery hoping that was the issue. No luck. Same problem. After that I found a loose connection on the negative of one of my batteries, tightened it and it worked fine after that. Yesterday the same issue started again. Checked all my connections and they were good. I could pull the motor up into the storage position and redeploy it and it would start working properly again. Has anyone ever has issues like this? Not sure if this is an issue with the motor or the remote.

Top
#12501293 - 11/12/17 02:49 PM Re: Motorguide XI5 Problems [Re: Tx Tree Grower]
UJC Offline
Extreme Angler

Registered: 01/12/07
Posts: 2180
Loc: Plano, TX
The remote was my first thought as I read your topic but you've change the battery and checked connections. I suggest calling Don at Boris Marine. They are an ASC and talk with them to see if they have encountered your type of issue and what the fix was.
_________________________
LIVE PURPLE LOVE GOLD
Geaux Tigers!
Jimmy

Top



© 1998-2018 OUTDOOR SITES NETWORK all rights reserved USA and Worldwide