Main Menu
Newest Members
CLove01, Chris Phillips, dac11011, Shrinermagic, bostonbassin
107384 Registered Users
Top Posters
TexDawg 88111
hopalong 78894
Pilothawk 76180
JDavis7873® 67390
John175® 66800
FattyMcButterpants 60846
Derek 🐝 59752
Tritonman 57915
LoneStarSon® 54253
SkeeterRonnie 53295
Forum Stats
107384 Members
60 Forums
873826 Topics
12418009 Posts

Max Online: 36273 @ 01/23/13 02:34 PM
Topic Options
#12501006 - 11/12/17 09:07 AM Motorguide XI5 Problems
Tx Tree Grower Offline
Pro Angler

Registered: 09/17/08
Posts: 814
Loc: Palestine, TX
Multiple times now I have had issues with my XI5. I operate it with a hand remote. It started with the turning being sluggish. It would either not move or turn very slow. It did it equally bad on both turn directions. I also had some issues with the prop on off command but nothing like the turn. I have had this unit since July. I replaced the remote battery hoping that was the issue. No luck. Same problem. After that I found a loose connection on the negative of one of my batteries, tightened it and it worked fine after that. Yesterday the same issue started again. Checked all my connections and they were good. I could pull the motor up into the storage position and redeploy it and it would start working properly again. Has anyone ever has issues like this? Not sure if this is an issue with the motor or the remote.

#12501293 - 11/12/17 02:49 PM Re: Motorguide XI5 Problems [Re: Tx Tree Grower]
UJC Online   content
Extreme Angler

Registered: 01/12/07
Posts: 2110
Loc: Plano, TX
The remote was my first thought as I read your topic but you've change the battery and checked connections. I suggest calling Don at Boris Marine. They are an ASC and talk with them to see if they have encountered your type of issue and what the fix was.
Geaux Tigers!


© 1998-2017 OUTDOOR SITES NETWORK all rights reserved USA and Worldwide