Main Menu
Advertisement
Affiliates
Advertisement
Newest Members
Stanley T, Mr Wiskers, Cat1, Khocevar, Bobbyw30
106151 Registered Users
Top Posters
TexDawg 86648
hopalong 78750
Pilothawk 75387
JDavis7873® 67383
John175 ® 65469
FattyMcButterpants 60793
Derek 🐝 58688
Tritonman 57667
LoneStarSon® 53554
SkeeterRonnie 53062
facebook
Forum Stats
106151 Members
60 Forums
807654 Topics
10207763 Posts

Max Online: 36273 @ 01/23/13 02:34 PM
Topic Options
#12461514 - 10/10/17 11:36 PM Lowrance HDS Gen 2 side imaging very weak on left side, does not work at all on right
rautery Online   content
Angler

Registered: 01/28/07
Posts: 281
Loc: Richardson
My Gen 2 HDS 7 side imaging quit working. In shallow water <10' it works out the left side but only out to 5-10 feet, on the right side it does not work at all, not picture whatsoever. The sonar works perfectly. I've done resets and changed settings, etc to no avail. I've tried multiple head units. Would this be the transducer or the hds box?

Thanks for any help.

Top
#12461573 - 10/11/17 06:01 AM Re: Lowrance HDS Gen 2 side imaging very weak on left side, does not work at all on right [Re: rautery]
GIG'EM AGGIES Offline
Extreme Angler

Registered: 05/14/14
Posts: 1913
Loc: texas
Sounds like the transducer to me but Lowrance Tech support has the answers. The electronics guys at BPS are pretty smart too.
_________________________
"Sometimes there just aren't enough rocks"
Forest Gump

Top



© 1998-2017 OUTDOOR SITES NETWORK all rights reserved USA and Worldwide