Main Menu
Newest Members
HaneyFishing, hirh68, Brett Fishes, NTBirddog, Tilefish
107378 Registered Users
Top Posters
TexDawg 88107
hopalong 78894
Pilothawk 76179
JDavis7873® 67390
John175® 66793
FattyMcButterpants 60846
Derek 🐝 59752
Tritonman 57914
LoneStarSon® 54253
SkeeterRonnie 53295
Forum Stats
107378 Members
60 Forums
873782 Topics
12417458 Posts

Max Online: 36273 @ 01/23/13 02:34 PM
Topic Options
#12428291 - 09/15/17 09:51 PM 150 opti exhaust question
bondsman Offline

Registered: 02/21/11
Posts: 25
Would there be a chance someone with more knowledge than I and I am a novice . might know what would cause the exhaust tube to snap two of the mounting stuits and break loose from the adapter plate at base of the powerhead? Thanks to all

#12428418 - 09/16/17 05:11 AM Re: 150 opti exhaust question [Re: bondsman]
gary purdy Online   content
TFF Guru

Registered: 05/24/03
Posts: 11369
Loc: Littlefield Tx & Lake A. H. US...
No good reason other than it is aluminum. I have been told it is a sign that the tuner isn`t getting enough water to cool it correctly. Yamahas are bad about it.
The world will not be destroyed by those who do evil, but by those who watch them without doing anything. Remember what He has done and remember that He is not done yet!-- GOD IS GOOD

#12428909 - 09/16/17 03:11 PM Re: 150 opti exhaust question [Re: bondsman]
bondsman Offline

Registered: 02/21/11
Posts: 25
Thanks very much Gary! I appreciate your input! GOD BLESS!


© 1998-2017 OUTDOOR SITES NETWORK all rights reserved USA and Worldwide