Main Menu
Newest Members
DRDawn, Dirk Parson, FEpic, Kroppie@Buchanan, Rwrshooter
107413 Registered Users
Top Posters
TexDawg 88138
Pilothawk 76210
JDavis7873® 67390
John175® 66835
FattyMcButterpants 60846
Derek 🐝 59786
Tritonman 57926
LoneStarSon® 54256
SkeeterRonnie 53303
Mark Perry 51831
Forum Stats
107413 Members
60 Forums
854658 Topics
12192671 Posts

Max Online: 36273 @ 01/23/13 02:34 PM
Topic Options
#12421660 - 09/10/17 07:38 PM Ultrex problem??
conroyz28 Offline

Registered: 10/17/16
Posts: 33
Had the boat out today. Everything working fine. Got to a new spot and put the trolling motor in the water and the pedal wouldn't budge. If I pushed really hard it would move the trolling head. But it seems the electronic motor is not working for some strange reason. It worked fine all day until the last spot. Any ideas. It's only 2 months old???

#12421867 - 09/10/17 09:04 PM Re: Ultrex problem?? [Re: conroyz28]
grout-scout Offline
TFF Celebrity

Registered: 12/08/08
Posts: 6722
Loc: Boerne, Texas
Common problem, you have to get the new control board. Call a service shop to get it fixed.

#12424916 - 09/13/17 08:52 AM Re: Ultrex problem?? [Re: conroyz28]
Jones Trolling Motor Offline
Pro Angler

Registered: 05/01/11
Posts: 523
Loc: NE Texas/SW Arkansas
This is a sensor board problem. Occurs in some motors built prior to August 1st. An ASC can get you back on the water.
texarkana, Ark/Tx

#12425099 - 09/13/17 11:02 AM Re: Ultrex problem?? [Re: conroyz28]
Muzzlebrake Offline
Extreme Angler

Registered: 12/26/14
Posts: 1664
Loc: Euless
A new Motorguide will fix the problem.
Sorry, I couldn't help myself:)
From Genesis: "And God promised men that good and obedient wives would be found in all corners of the earth."

Then He made the earth round...and He laughed and laughed and laughed!


© 1998-2017 OUTDOOR SITES NETWORK all rights reserved USA and Worldwide