Main Menu
Advertisement
Affiliates
Advertisement
Newest Members
SouthernC10, Drewski05, Wayne68, Tanner101, Fras
108454 Registered Users
Top Posters
TexDawg 89124
hopalong 78895
Pilothawk 76603
John175® 68178
JDavis7873® 67391
FattyMcButterpants 60904
Derek 🐝 60699
Tritonman 58116
LoneStarSon® 54600
SkeeterRonnie 53487
facebook
Forum Stats
108454 Members
61 Forums
777633 Topics
10030452 Posts

Max Online: 36273 @ 01/23/13 02:34 PM
Topic Options
#12412534 - 09/03/17 03:20 PM helix 10 no SI on right side
MikeW07 Offline
Angler

Registered: 05/07/04
Posts: 296
Loc: Keller Texas
Ive got a helix 10 mega and seem to have lost the right side of side imaging - left looks perfect and I had right side before - I did the factory restore and it seemed to help a very little still no image on the right - transducer seems fine and nothing in the way of the beam

Any help appreciated.

Top
#12412565 - 09/03/17 04:03 PM Re: helix 10 no SI on right side [Re: MikeW07]
44 Diesel Online   content
TFF Celebrity

Registered: 12/25/12
Posts: 5237
Loc: Burleson,TX
Are you using a y cable for a separate 2d transducer?. If so plug the si transducer straight to the unit and see what ya get. If not gonna need to call Humminbird C/S, some mega transducers have been having issues with the si elements going out


Edited by 44 Diesel (09/03/17 04:04 PM)

Top
#12412616 - 09/03/17 05:11 PM Re: helix 10 no SI on right side [Re: MikeW07]
Capt Craig Online   content
Extreme Angler

Registered: 08/25/09
Posts: 1620
Loc: Richland-Chambers
Two possibilities. The unit is set only to show the left side or a transducer failure. Confirm your SI setting.
_________________________
Capt. Craig Copeland
Licensed by the US Coast Guard

2013 Nautic Star 2110 Shallow Bay Boat
Humminbird HELIX 12 CHIRP MEGA SI GPS G2N
Nautic Star Boats Pro Staff (nauticstarboats.com)
Redneck Fish'n Jigs Pro Staff (redneckfishn.com)

Top



© 1998-2018 OUTDOOR SITES NETWORK all rights reserved USA and Worldwide