Main Menu
Advertisement
Affiliates
Advertisement
Newest Members
Stickfish36, Ruler1, TomSawyer, poolsj, Tonemerchant
105730 Registered Users
Top Posters
TexDawg 85945
hopalong 78098
Pilothawk 75038
JDavis7873® 67382
John175 ® 64794
FattyMcButterpants 60790
Derek 🐝 58262
Tritonman 57558
LoneStarSon® 53252
SkeeterRonnie 52975
facebook
Forum Stats
105730 Members
60 Forums
801744 Topics
10133575 Posts

Max Online: 36273 @ 01/23/13 02:34 PM
Topic Options
#12376110 - 08/07/17 12:32 PM Mercury Pro XS Oil Pump
StratVoodoo Offline
Outdoorsman

Registered: 04/14/15
Posts: 135
Loc: Kaufman County, TX
I've noticed a lot of feedback from folks on other boating sites regarding leaking oil pumps on Mercury Pro XS & Optimax motors. Mine (2011 Pro XS 200 w/ approximately 130 Hours) is currently in the shop for the same issue. My question is, has Mercury addressed the issues within the replacement parts (apparantly an internal O-ring), or could this possibly be a recurring issue? I understand mechanical parts wear & it's a roll of the dice on how long they'll last, just wondering if anyone has had this experience and what the longevity or the replacement is. And yes, I'm running Mercury DFI oil & have all other maintenance items performed regularly.


Edited by StratVoodoo (08/07/17 12:36 PM)

Top
#12376257 - 08/07/17 02:26 PM Re: Mercury Pro XS Oil Pump [Re: StratVoodoo]
grout-scout Online   content
TFF Celebrity

Registered: 12/08/08
Posts: 6109
Loc: Boerne, Texas
Did you try to tighten the bolts before taking it in? Mine was leaking and it was just loose bolts.

Top
#12377050 - 08/08/17 06:06 AM Re: Mercury Pro XS Oil Pump [Re: grout-scout]
StratVoodoo Offline
Outdoorsman

Registered: 04/14/15
Posts: 135
Loc: Kaufman County, TX
Originally Posted By: grout-scout
Did you try to tighten the bolts before taking it in? Mine was leaking and it was just loose bolts.
Yes sir

Top



© 1998-2017 OUTDOOR SITES NETWORK all rights reserved USA and Worldwide