Main Menu
Advertisement
Affiliates
Advertisement
Newest Members
jfur, dburt2, AMG, ntxduffer, OKBlindHogg
108024 Registered Users
Top Posters
TexDawg 88644
hopalong 78895
Pilothawk 76394
John175® 67601
JDavis7873® 67390
FattyMcButterpants 60868
Derek 🐝 60292
Tritonman 57993
LoneStarSon® 54406
SkeeterRonnie 53367
facebook
Forum Stats
108024 Members
60 Forums
861388 Topics
12276400 Posts

Max Online: 36273 @ 01/23/13 02:34 PM
Topic Options
#12342461 - 07/16/17 11:53 AM Helix 12 question
Blue Blazer 2400 Offline
Extreme Angler

Registered: 02/23/05
Posts: 1391
Loc: Royse City, Tx
I am on the lake and my Humminbird Helix 12 Mega is not reading side imaging or down imaging? Anybody have any suggestions?

Top
#12342466 - 07/16/17 11:55 AM Re: Helix 12 question [Re: Blue Blazer 2400]
Bobby Milam Offline
TFF Team Angler

Registered: 07/13/14
Posts: 3382
Loc: Arlington
Check to make sure that you have the correct transducer chosen in your menu. If it is pulling up the screen but not giving a good reading, check the transducer to ensure it hasn't flipped up.

Top
#12345442 - 07/18/17 07:46 AM Re: Helix 12 question [Re: Blue Blazer 2400]
Corey Stanley Offline
Extreme Angler

Registered: 10/26/09
Posts: 1012
Loc: Tx
Also be sure that the transducer is plugged in well in the back of the unit. Sometimes during travel they can work there way just a little lose and it will not be making a good connection. Pull the plug off the back and make sure all of the individual connectors are pushed all the way in the collector and then plug back in and restart. The guy that just bought my 2017 boat was having a similar issue on his first trip out and this did the trick.
_________________________
www.navionics.com

Top



© 1998-2018 OUTDOOR SITES NETWORK all rights reserved USA and Worldwide