Main Menu
Advertisement
Affiliates
Advertisement
Newest Members
WTXBA806, robbiehoover, texasggm, bassjerker112, EHC
108878 Registered Users
Top Posters
TexDawg 89591
hopalong 78895
Pilothawk 76928
John175® 68859
JDavis7873® 67392
Derek 🐝 61251
FattyMcButterpants 60904
Tritonman 58254
LoneStarSon® 54732
SkeeterRonnie 53594
facebook
Forum Stats
108878 Members
61 Forums
832779 Topics
12100126 Posts

Max Online: 36273 @ 01/23/13 02:34 PM
Topic Options
#12323624 - 07/04/17 12:35 PM Mercury trim sending unit?
Poodle Offline
Green Horn

Registered: 07/01/17
Posts: 8
Loc: Breckenridge, Tx
I just purchased a new to me boat. It is a 94 model in excellent shape. It has a 09 model 50hp Mercury engine on it. I noticed the trim gauge was not working on the boat and the man selling it on consignment said he figured it just had a loose wire. I check all of the wiring at the gauge and it has power but when I searched for a sending unit back on the engine I could not find one. I searched out the parts manual and it does not show one for this engine. My s/n is 1B742942. Does any one know of a sending unit that would work with this engine?
Thanks, Steve
_________________________
Steve

Top
#12327404 - 07/06/17 08:54 PM Re: Mercury trim sending unit? [Re: Poodle]
OPTI Offline
Extreme Angler

Registered: 06/23/04
Posts: 1473
Loc: Benbrook Tex
Part # 822573A12


Edited by OPTI (07/06/17 08:54 PM)

Top
#12327413 - 07/06/17 09:00 PM Re: Mercury trim sending unit? [Re: Poodle]
Poodle Offline
Green Horn

Registered: 07/01/17
Posts: 8
Loc: Breckenridge, Tx
Thanks man just the info I was looking for.
Steve
_________________________
Steve

Top



© 1998-2018 OUTDOOR SITES NETWORK all rights reserved USA and Worldwide