Main Menu
Advertisement
Affiliates
Advertisement
Newest Members
Sanger jigman, PkurioFishN, Possum67, wormwiggler20, rdbalcom
107732 Registered Users
Top Posters
TexDawg 88362
Pilothawk 76320
JDavis7873® 67390
John175® 67188
FattyMcButterpants 60846
Derek 🐝 60031
Tritonman 57950
LoneStarSon® 54314
SkeeterRonnie 53336
Mark Perry 52109
facebook
Forum Stats
107732 Members
60 Forums
807677 Topics
10230258 Posts

Max Online: 36273 @ 01/23/13 02:34 PM
Page 1 of 2 1 2 >
Topic Options
#12311134 - 06/25/17 09:37 PM Motorguide Xi5 Anchor Mode
Patrick M Offline
Pro Angler

Registered: 11/16/08
Posts: 653
Loc: Weatherford, TX


Hoping someone has had this issue and can be of some help. I have been able to take my boat out 3 times this year and each time I have problems with my Xi5. Last season it worked great and I never had any problems, but this year, I have had nothing but problems. The motor itself works great but when I attempt to put it into anchor mode the satellite light flashes for about 10-15 seconds and then stops, gives me the error tone, and goes back into manual mode. I have taken the motor to Boris Marine twice and they are apparently unable to repair the motor. The first time I took it, they said it was a bad GPS module, they replaced that and sent me on my way. I took it out, did the same thing that it had been doing. The second time, they replaced the entire board. I was finally able to take it out today and it was still doing the same thing. I have called Motorguide, they just tell me to take it to an ASC, but nothing is getting done about the problem. I have unplugged the unit starting with the negative wire multiple times, reset to factory calibration, setup the keel calibration, calibrated the GPS by traveling in a circle 2 times (I even get the confirmation beep), I replaced all 3 batteries to make sure that wasn't the problem, when on the charger I am getting 39V, so I know the voltage is there. I have synced and re-synced the remote a few times, even bought a foot pedal to see if the remote was the problem... nope. I am tired of having to take this TM 40 miles each way for an ASC to not be able to repair the issue. I was told by Boris Marine that they would not be replacing the motor even though it is under warranty and seemingly cannot be repaired. Im beyond frustrated with this unit and would love some advice or experiences to help me out. Thanks in advance!


Top
#12311434 - 06/26/17 03:53 AM Re: Motorguide Xi5 Anchor Mode [Re: Patrick M]
javelin150 Offline
Pro Angler

Registered: 03/19/06
Posts: 928
Loc: Waco, TX
Have the tried the software update for the trolling motor? You can call Motorguide and they will send you dongle that plugs into your nmea system and it will do a software update that can help fix issue with the gps function of the trolling motor.

Top
#12311450 - 06/26/17 05:40 AM Re: Motorguide Xi5 Anchor Mode [Re: Patrick M]
Patrick M Offline
Pro Angler

Registered: 11/16/08
Posts: 653
Loc: Weatherford, TX
MG told me on the phone that my motor was manufactured after that update was already loaded on the motor. So it wouldn't work for me. However, Boris Marine states that they loaded the dongle update on the motor after the first time I took it up there. I had heard of this previously and thought it was the first thing to look into.

Top
#12311455 - 06/26/17 06:09 AM Re: Motorguide Xi5 Anchor Mode [Re: Patrick M]
javelin150 Offline
Pro Angler

Registered: 03/19/06
Posts: 928
Loc: Waco, TX
Have you checked your nmea system? Is the nmea backbone getting power?

Top
#12311514 - 06/26/17 07:38 AM Re: Motorguide Xi5 Anchor Mode [Re: Patrick M]
Patrick M Offline
Pro Angler

Registered: 11/16/08
Posts: 653
Loc: Weatherford, TX
Yes, my NMEA is getting power, but I do not have this hooked up to my NMEA system right now.

Top
#12312058 - 06/26/17 01:23 PM Re: Motorguide Xi5 Anchor Mode [Re: Patrick M]
shut-up-and-fish Offline
TFF Guru

Registered: 02/08/10
Posts: 10224
Loc: Lewisville Tx.

It does not matter if you have had the software update already. If you have lost satellite connection the software update "AGAIN" will resolve the matter most cases....
_________________________

www.shut-up-and-fish.com
It's all coming together and we have you covered @ Shut-Up-And-Fish LLC
From *Sales *Installation Services *On the Water Education & Instructional Trips
we are your One-Stop-Shop for all Humminbird MinnKota & Motorguide needs & more
972 822 9285

Top
#12315255 - 06/28/17 03:10 PM Re: Motorguide Xi5 Anchor Mode [Re: Patrick M]
voodew Offline
Outdoorsman

Registered: 03/07/15
Posts: 83
I had the same thing happen when I got mine well over 2 yrs agao --- they had to send me a flash drive to plug into the unit and reprogram it.
This used to happen if you deployed the trolling motor (or put power to it while the batteries were charging (to high of voltage)
Never had the issue again but I also never deploy the trolling motor when the batteries are charging

Top
#12315846 - 06/28/17 08:32 PM Re: Motorguide Xi5 Anchor Mode [Re: Patrick M]
Patrick M Offline
Pro Angler

Registered: 11/16/08
Posts: 653
Loc: Weatherford, TX
My first action was calling MG and asked them to send me the dongle. They refused and said that my unit was manufactured post update and it wouldn't help. I'm taking the TM to the shop again tomorrow.

Top
#12316148 - 06/28/17 11:13 PM Re: Motorguide Xi5 Anchor Mode [Re: Patrick M]
Bobby Milam Offline
TFF Team Angler

Registered: 07/13/14
Posts: 3301
Loc: Arlington
3rd time would be my last time. If it doesn't get fixed this time, I'd start moving my complaint up the chain of command and demanding it be replaced. Hopefully they'll figure it out this time but if not the squeaky wheel gets the grease.

Top
#12317502 - 06/29/17 07:58 PM Re: Motorguide Xi5 Anchor Mode [Re: Patrick M]
Patrick M Offline
Pro Angler

Registered: 11/16/08
Posts: 653
Loc: Weatherford, TX
Update was installed today and fixed the problem.

Top
#12317584 - 06/29/17 08:45 PM Re: Motorguide Xi5 Anchor Mode [Re: Patrick M]
Bobby Milam Offline
TFF Team Angler

Registered: 07/13/14
Posts: 3301
Loc: Arlington
Congrats and thanks for updating

Top
#12317674 - 06/29/17 09:44 PM Re: Motorguide Xi5 Anchor Mode [Re: Patrick M]
bronco71 Offline
Extreme Angler

Registered: 02/05/06
Posts: 1431
Loc: Farmers Branch/Sulphur Bluff
Thanks for letting us know the outcome, I have an Xi5 on the way!

Top
#12318352 - 06/30/17 10:43 AM Re: Motorguide Xi5 Anchor Mode [Re: Patrick M]
Patrick M Offline
Pro Angler

Registered: 11/16/08
Posts: 653
Loc: Weatherford, TX
When it's working, it's spot on!

Top
#12318403 - 06/30/17 11:14 AM Re: Motorguide Xi5 Anchor Mode [Re: Patrick M]
lipjerk Offline
Extreme Angler

Registered: 03/04/09
Posts: 2309
Loc: Lantana,Tx
I had the same problem with mine when new, GPS module was replaced, and no problems since. I took mine to All Star Archery in Lewisville, they are an authorized MG repair facility, mine was repaired and back to me in a day.

All Star Archery & Marine
www.allstarmarine.com
201 S Mill St, Lewisville, TX 75057 · ~1.8 mi
(469) 549-1850
Open until 6 PM

Top
#12457749 - 10/08/17 09:34 AM Re: Motorguide Xi5 Anchor Mode [Re: Patrick M]
Patrick M Offline
Pro Angler

Registered: 11/16/08
Posts: 653
Loc: Weatherford, TX
Well today the same issue resurfaced. Looks like I’ll have to get it reflagged again....

Top
Page 1 of 2 1 2 >



© 1998-2018 OUTDOOR SITES NETWORK all rights reserved USA and Worldwide