Main Menu
Newest Members
RodRaider55, CoachBlackburn, Dug1970, K-Machado, RadarLuv
107363 Registered Users
Top Posters
TexDawg 88104
hopalong 78894
Pilothawk 76176
JDavis7873® 67390
John175® 66790
FattyMcButterpants 60846
Derek 🐝 59752
Tritonman 57914
LoneStarSon® 54248
SkeeterRonnie 53292
Forum Stats
107363 Members
60 Forums
823628 Topics
10415640 Posts

Max Online: 36273 @ 01/23/13 02:34 PM
Topic Options
#12303508 - 06/20/17 08:18 PM Motorguide xi5
gapple Offline
Green Horn

Registered: 01/25/17
Posts: 7
Loc: 76078
While fishing the wireless pedal on my xi5 stopped working. Meaning the momentary switch nor the on/off operated the motor. Thought it was the batteries so I changed them. Still wouldn't work.
Everything works using the hand held remote. Pedal will still cycle on/off but will not operate the motor.

Pedal also feels stiffer then normal.

I baby this thing and don't abuse it.

Any ideas?

#12310343 - 06/25/17 12:18 AM Re: Motorguide xi5 [Re: gapple]
oakpointaggie Offline

Registered: 04/02/16
Posts: 141
I'm having a red light on my battery indicator and low power. I know this could be batteries but I charged them for 10 days on my triple bank charger and the red light is still on. Any thoughts?

#12310367 - 06/25/17 04:47 AM Re: Motorguide xi5 [Re: gapple]
javelin150 Online   content
Pro Angler

Registered: 03/19/06
Posts: 913
Loc: Waco, TX
Have you tried replacing the batteries in the bottom of the foot pedal?

#12310725 - 06/25/17 02:11 PM Re: Motorguide xi5 [Re: gapple]
shut-up-and-fish Online   content
TFF Guru

Registered: 02/08/10
Posts: 10158
Loc: Lewisville Tx.

Be sure you did not turn it off.

Try re-syncing the foot pedal...
It's all coming together and we have you covered @ Shut-Up-And-Fish LLC
From *Sales *Installation Services *On the Water Education & Instructional Trips
we are your One-Stop-Shop for all Humminbird MinnKota & Motorguide needs & more
972 822 9285

#12311515 - 06/26/17 07:40 AM Re: Motorguide xi5 [Re: gapple]
gapple Offline
Green Horn

Registered: 01/25/17
Posts: 7
Loc: 76078
Yes I did change the foot pedal batteries. Had to re-sync the pedal. All is good now.

Thanks to those that responded.


© 1998-2017 OUTDOOR SITES NETWORK all rights reserved USA and Worldwide