Main Menu
Newest Members
beard, Bowhunter2323, BankAngler81, CLove01, Chris Phillips
107387 Registered Users
Top Posters
TexDawg 88111
hopalong 78894
Pilothawk 76183
JDavis7873® 67390
John175® 66800
FattyMcButterpants 60846
Derek 🐝 59754
Tritonman 57915
LoneStarSon® 54253
SkeeterRonnie 53296
Forum Stats
107387 Members
60 Forums
823848 Topics
10418256 Posts

Max Online: 36273 @ 01/23/13 02:34 PM
Topic Options
#12270515 - 05/30/17 09:29 PM Mercruiser 3.0 Bogging Problem
KyleW Offline

Registered: 04/10/13
Posts: 429
Loc: Allen, TX
Have a 1994 Bayliner 1950 Capri with the 3.0 Mercruiser that has a couple problems.
First off, the boat is hard to start. Gas is fresh as I use the boat almost daily. Engine can be ran for 30 minutes WOT and if I shut it off and try to start it, it will be just as hard to start as it is cold. I can usually get it to start by putting it in neutral and pumping the gas while turning the key.
Second, the boat bogs down at a certain point of the throttle. It's not far after idle speed. It'll bog, but if I keep pushing down on the throttle it will break through and rev up. Does not matter cold or hot engine, it still does it at the same spot.

I believe it is an adjustment that needs to be done since we got the throttle handle replaced a year or so ago. I'm unfamiliar with boat engines but pretty handy with four wheeler/small engines, so I'm sure I can adjust it but don't know where to start or where to look on the engine. If anybody has any tips, it would be greatly appreciated!

#12270751 - 05/31/17 06:00 AM Re: Mercruiser 3.0 Bogging Problem [Re: KyleW]
gary purdy Offline
TFF Guru

Registered: 05/24/03
Posts: 11371
Loc: Littlefield Tx & Lake A. H. US...
Sounds like the Carb needs rebuilt.
The world will not be destroyed by those who do evil, but by those who watch them without doing anything. Remember what He has done and remember that He is not done yet!-- GOD IS GOOD


© 1998-2017 OUTDOOR SITES NETWORK all rights reserved USA and Worldwide