Main Menu
Newest Members
HaneyFishing, hirh68, Brett Fishes, NTBirddog, Tilefish
107378 Registered Users
Top Posters
TexDawg 88108
hopalong 78894
Pilothawk 76180
JDavis7873® 67390
John175® 66794
FattyMcButterpants 60846
Derek 🐝 59752
Tritonman 57914
LoneStarSon® 54253
SkeeterRonnie 53295
Forum Stats
107378 Members
60 Forums
873782 Topics
12417507 Posts

Max Online: 36273 @ 01/23/13 02:34 PM
Topic Options
#12268965 - 05/30/17 07:17 AM Minn Kota Ultrex questions
CartersFishingAdventures Offline

Registered: 09/08/15
Posts: 168
is there anybody in DFW that can install or trouble shoot this style trolling motor?

I have installed mine and did not do something right obviously. the ultrex works for little bit then you will let off the foot pedal button and it will just stay running the prop. then when in spot lock sometimes it just goes off and starts to taking off in any direction on constant power.

need help figuring it out. if there somebody on here that knows people that travels around that can help trouble shoot and install everything to the puck and graph let me know please.
John W Carter
enigma fishing pro staff
Woo Tungsten pro staff

#12269131 - 05/30/17 08:57 AM Re: Minn Kota Ultrex questions [Re: CartersFishingAdventures]
Bobby Milam Online   content
TFF Team Angler

Registered: 07/13/14
Posts: 3224
Loc: Arlington
If start by calling Minn Kota and talking to their support people

#12269201 - 05/30/17 09:36 AM Re: Minn Kota Ultrex questions [Re: CartersFishingAdventures]
wtf242 Offline

Registered: 10/26/16
Posts: 151
Loc: Austin, TX
I would call Minn Kota. Unfortunately It's so new they do not repair them. They will just send you a new one. The manual steering on mine broke and they got me a new one within a week

#12269247 - 05/30/17 10:07 AM Re: Minn Kota Ultrex questions [Re: CartersFishingAdventures]
forkduc Offline
TFF Guru

Registered: 03/28/07
Posts: 11578
Loc: Plano,Texas
Try Plano Marine. They did mine.

#12269280 - 05/30/17 10:27 AM Re: Minn Kota Ultrex questions [Re: CartersFishingAdventures]
redmojo Offline
Pro Angler

Registered: 03/02/14
Posts: 669
It sounds like your armature is defective. This happened to ours and they replaced it at Sartine Marine on the spot. As far as the spot-lock goes, did you calibrate it yet?


© 1998-2017 OUTDOOR SITES NETWORK all rights reserved USA and Worldwide