Main Menu
Advertisement
Affiliates
Advertisement
Newest Members
bigrednuffsaid, fredericksburg girl, Larry Mc, Minnow Man779, Steven75002
107120 Registered Users
Top Posters
TexDawg 87880
hopalong 78878
Pilothawk 76060
JDavis7873® 67389
John175® 66459
FattyMcButterpants 60846
Derek 🐝 59590
Tritonman 57891
LoneStarSon® 54173
SkeeterRonnie 53242
facebook
Forum Stats
107120 Members
60 Forums
871052 Topics
12381198 Posts

Max Online: 36273 @ 01/23/13 02:34 PM
Topic Options
#12020091 - 01/04/17 02:04 PM Problem with a brush
swalker9513 Online   content
TFF Celebrity

Registered: 01/04/02
Posts: 8407
I have an old Badger brush that someone gave me. It has worked before, but seems to not be working now. I would like to get it working to spray metallics and base coats because it has a giant needle. So, here is what is happening.

When I push the trigger, all it does is psst. No air. I've taken it apart and cleaned it multiple times, but still get a pfft. So I took the air valve out and connected it to the hose and pressed the valve open...plenty of air. So, the valve is working but not getting air out of the brush. Any ideas?
_________________________


www.wildcranks.com or find them at Fun-N-Sun in Hurst.

Top
#12020139 - 01/04/17 02:32 PM Re: Problem with a brush [Re: swalker9513]
Txmedic033 Offline
TFF Team Angler

Registered: 08/13/13
Posts: 4330
Loc: Longview, Tx
Is the needle pulling back out of the way? Does is spray when the needle isn't in the brush?

Top
#12020258 - 01/04/17 03:33 PM Re: Problem with a brush [Re: swalker9513]
swalker9513 Online   content
TFF Celebrity

Registered: 01/04/02
Posts: 8407
Took the nozzle assembly off. No air. The little "passage" the air flows through is clear. I've checked schematics and nothing is missing. I'm at a loss.

I'm beginning to think that maybe the o-ring is worn and is not staying in place
_________________________


www.wildcranks.com or find them at Fun-N-Sun in Hurst.

Top
#12020359 - 01/04/17 04:19 PM Re: Problem with a brush [Re: swalker9513]
swalker9513 Online   content
TFF Celebrity

Registered: 01/04/02
Posts: 8407
Pretty sure that's what it is. I must have left the air valve on when I submerged it to clean it. After letting it sit on my desk for a little while, it worked better. Gonna let it dry for several hours and gonna try it again.
_________________________


www.wildcranks.com or find them at Fun-N-Sun in Hurst.

Top
#12022251 - 01/05/17 01:38 PM Re: Problem with a brush [Re: swalker9513]
swalker9513 Online   content
TFF Celebrity

Registered: 01/04/02
Posts: 8407
That was it.
_________________________


www.wildcranks.com or find them at Fun-N-Sun in Hurst.

Top



© 1998-2017 OUTDOOR SITES NETWORK all rights reserved USA and Worldwide