Main Menu
Advertisement
Affiliates
Advertisement
Newest Members
HughGass, Hockley, jl44, firemom2bay, Clynn5
108006 Registered Users
Top Posters
TexDawg 88614
hopalong 78895
Pilothawk 76392
John175® 67565
JDavis7873® 67390
FattyMcButterpants 60868
Derek 🐝 60254
Tritonman 57991
LoneStarSon® 54396
SkeeterRonnie 53366
facebook
Forum Stats
108006 Members
60 Forums
811075 Topics
10272332 Posts

Max Online: 36273 @ 01/23/13 02:34 PM
Topic Options
#11952811 - 11/26/16 10:09 PM MG trolling motor isn't getting power
Baszin Offline
Extreme Angler

Registered: 04/09/08
Posts: 1427
Loc: Keller
Anyone dealt with this or know a good repair place to take it to. Have brand new batteries and can get power at the top of the trolling motor cause the arrow lights up but the prop doesn't go. Hoping I don't have to replace. Any suggestions
_________________________
Tomorrow is the first day of the rest of your life

Top
#11952821 - 11/26/16 10:23 PM Re: MG trolling motor isn't getting power [Re: Baszin]
D Kissinger Offline
Outdoorsman

Registered: 10/14/09
Posts: 135
Loc: Granbury, TX
Make sure there isnt any fishing line wrapped up behind the prop. Ive had that before and it kept the prop from spinning.
_________________________
1984 Ranger 372V 1984 Johnson 140
1998 Fisher FX19 Tournament 1998 Mercury 200

Top
#11952858 - 11/26/16 11:04 PM Re: MG trolling motor isn't getting power [Re: Baszin]
jackson_ranger Offline
Angler

Registered: 01/21/16
Posts: 432
Loc: Wise County
I've been having issues with mine too, it's an older model. I just figured out that the plug was not getting a good connection... I know... should have been the first thing I checked. I've heard of a good shop over here in Fort Worth that won't do you wrong... I'll have to try to find their name tho.
_________________________
1997 Ranger 488VS

Proud Veteran

Top
#11952871 - 11/26/16 11:34 PM Re: MG trolling motor isn't getting power [Re: Baszin]
K.D. Offline
TFF Guru

Registered: 05/04/02
Posts: 14240
Loc: Hurst, TX
Boris Marine

Top
#11952877 - 11/27/16 12:02 AM Re: MG trolling motor isn't getting power [Re: Baszin]
Baszin Offline
Extreme Angler

Registered: 04/09/08
Posts: 1427
Loc: Keller
Thx guys, have checked both for obstruction and plug is good. It's an 07 tour digital 109, what would I be looking at if I had to replace lower part of the unit
_________________________
Tomorrow is the first day of the rest of your life

Top
#11953017 - 11/27/16 08:16 AM Re: MG trolling motor isn't getting power [Re: Baszin]
FishingTexan Offline
Outdoorsman

Registered: 11/25/12
Posts: 206
Loc: Mansfield, TX
I had the same issue with my Motor Guide digital. Boris Marine did the repair. My problem was the digital motor controller board in the lower unit. Since the lower unit had to come apart, I had all the bushings, seals and brush assembly replaced as well. The repair came with a one year parts and labor warranty. If only your brushes are bad, the repair cost will be significantly less. Boris was great about informing me of the potential expense along the way since the controller board was an expensive part. In the end the repair was about 30% of what a replacement trolling motor would have cost and was completed in a week.

There are a couple of wire nuts in the head of the trolling motor that connect the lower unit wiring to power. Check to make sure there are good connections at that point. A loose connection there would allow the arrow indicator to light but no power to the motor.

Top
#11953040 - 11/27/16 08:46 AM Re: MG trolling motor isn't getting power [Re: Baszin]
Mike_Soriano™ Offline
TFF Celebrity

Registered: 06/08/08
Posts: 5434
Loc: FORK
^^^this
_________________________
www.XciteBaits.com
www.Daiwa.com


Top
#11953311 - 11/27/16 12:08 PM Re: MG trolling motor isn't getting power [Re: Baszin]
Baszin Offline
Extreme Angler

Registered: 04/09/08
Posts: 1427
Loc: Keller
Thanks guys, great info will check both out
_________________________
Tomorrow is the first day of the rest of your life

Top



© 1998-2018 OUTDOOR SITES NETWORK all rights reserved USA and Worldwide