Main Menu
Advertisement
Affiliates
Advertisement
Newest Members
creaturefeature, charlesc, Lrs21, mbparker, Dan O
104814 Registered Users
Top Posters
TexDawg 84898
hopalong 77274
Pilothawk 74627
JDavis7873® 67382
John175 ® 63148
FattyMcButterpants 60665
Derek 🐝 57563
Tritonman 57448
SkeeterRonnie 52885
LoneStarSon® 52797
facebook
Forum Stats
104814 Members
60 Forums
791271 Topics
10002685 Posts

Max Online: 36273 @ 01/23/13 02:34 PM
Topic Options
#11840200 - 09/20/16 08:21 PM I pilot link trouble???
txhighcaliber Offline
Outdoorsman

Registered: 06/05/12
Posts: 51
Loc: Possum kingdom
I have an I pilot link added onto my powerdrive v2 and all of a sudden it will not work. I thought my batteries were dead so I charged them and still not working. When I turn on my remote it says "motor not found". When I hold down the "learn" button on the head of the trolling motor it will not beep to connect to my remote. . Ive searched all over online and can't figure it out so hoping someone here can please help. Thanks in advance.
_________________________
Molôn Labé!

Top
#11840452 - 09/20/16 10:55 PM Re: I pilot link trouble??? [Re: txhighcaliber]
D Miner Offline
Outdoorsman

Registered: 03/06/14
Posts: 199
Are you sure the 100% sure the trolling motor is receiving power? Check the appropriate circuit breaker.

Top
#11840456 - 09/20/16 10:58 PM Re: I pilot link trouble??? [Re: D Miner]
txhighcaliber Offline
Outdoorsman

Registered: 06/05/12
Posts: 51
Loc: Possum kingdom
Originally Posted By: D Miner
Are you sure the 100% sure the trolling motor is receiving power? Check the appropriate circuit breaker.


At the bottom of the trolling motor the lights all light up when I hit the test button to indicate full battery so I'm believe it is getting power
_________________________
Molôn Labé!

Top
#11841064 - 09/21/16 11:37 AM Re: I pilot link trouble??? [Re: txhighcaliber]
txhighcaliber Offline
Outdoorsman

Registered: 06/05/12
Posts: 51
Loc: Possum kingdom
Taking it to Boris marine electronics later so I'm sure he will get me fixed up
_________________________
Molôn Labé!

Top
#11841420 - 09/21/16 02:47 PM Re: I pilot link trouble??? [Re: txhighcaliber]
TCK73 Offline
Extreme Angler

Registered: 03/26/15
Posts: 2529
Loc: Jack County
Yep, Ron can do it, good shop.
_________________________


Top



© 1998-2017 OUTDOOR SITES NETWORK all rights reserved USA and Worldwide