Main Menu
Advertisement
Affiliates
Advertisement
Newest Members
Body, DJ's Woodshop, TEut, RedRaiders, toledobendbass
102129 Registered Users
Top Posters
TexDawg 81813
hopalong 72997
Pilothawk 72511
JDavis7873® 67373
FattyMcButterpants 60428
John175 ® 59617
Tritonman 56448
Derek 55967
SkeeterRonnie 52351
LoneStarSon® 51907
facebook
Forum Stats
102124 Members
60 Forums
850655 Topics
11154526 Posts

Max Online: 36273 @ 01/23/13 02:34 PM
Topic Options
#11840200 - 09/20/16 08:21 PM I pilot link trouble???
txhighcaliber Online   content
Outdoorsman

Registered: 06/05/12
Posts: 41
Loc: Possum kingdom
I have an I pilot link added onto my powerdrive v2 and all of a sudden it will not work. I thought my batteries were dead so I charged them and still not working. When I turn on my remote it says "motor not found". When I hold down the "learn" button on the head of the trolling motor it will not beep to connect to my remote. . Ive searched all over online and can't figure it out so hoping someone here can please help. Thanks in advance.
_________________________
Molôn Labé!

Top
#11840452 - 09/20/16 10:55 PM Re: I pilot link trouble??? [Re: txhighcaliber]
D Miner Offline
Outdoorsman

Registered: 03/06/14
Posts: 122
Are you sure the 100% sure the trolling motor is receiving power? Check the appropriate circuit breaker.

Top
#11840456 - 09/20/16 10:58 PM Re: I pilot link trouble??? [Re: D Miner]
txhighcaliber Online   content
Outdoorsman

Registered: 06/05/12
Posts: 41
Loc: Possum kingdom
Originally Posted By: D Miner
Are you sure the 100% sure the trolling motor is receiving power? Check the appropriate circuit breaker.


At the bottom of the trolling motor the lights all light up when I hit the test button to indicate full battery so I'm believe it is getting power
_________________________
Molôn Labé!

Top
#11841064 - 09/21/16 11:37 AM Re: I pilot link trouble??? [Re: txhighcaliber]
txhighcaliber Online   content
Outdoorsman

Registered: 06/05/12
Posts: 41
Loc: Possum kingdom
Taking it to Boris marine electronics later so I'm sure he will get me fixed up
_________________________
Molôn Labé!

Top
#11841420 - 09/21/16 02:47 PM Re: I pilot link trouble??? [Re: txhighcaliber]
TCK73 Online   content
Extreme Angler

Registered: 03/26/15
Posts: 1502
Loc: Jack County
Yep, Ron can do it, good shop.
_________________________


Top



© 1998-2016 OUTDOOR SITES NETWORK all rights reserved USA and Worldwide