Main Menu
Advertisement
Affiliates
Advertisement
Newest Members
hillcountrybass, Linda Robert, Gnhattien, Robert black, Calexander
102726 Registered Users
Top Posters
TexDawg 82877
hopalong 74395
Pilothawk 73437
JDavis7873® 67377
FattyMcButterpants 60518
John175 ® 59900
Tritonman 56831
Derek 56424
SkeeterRonnie 52463
LoneStarSon® 52225
facebook
Forum Stats
102726 Members
61 Forums
859160 Topics
11271181 Posts

Max Online: 36273 @ 01/23/13 02:34 PM
Topic Options
#11836167 - 09/18/16 08:31 PM Hummingbird problems!
BeardedBanker Offline
Pro Angler

Registered: 01/06/13
Posts: 502
Loc: Queen City, TX
I have a Hummingbird 958c on bow of my boat. Last couple of weeks it started powering off on its own. I can turn it back on and then I'll look down and it's off again. Any ideas?

Top
#11836171 - 09/18/16 08:34 PM Re: Hummingbird problems! [Re: BeardedBanker]
coachallentca Online   content
TFF Team Angler

Registered: 11/19/08
Posts: 3743
Loc: crowley
good be a bad battery
_________________________



Top
#11836186 - 09/18/16 08:38 PM Re: Hummingbird problems! [Re: BeardedBanker]
NITRO Z8 Online   content
Angler

Registered: 07/06/07
Posts: 482
Loc: fortworth tx, tarrant co.
Check your connections because mine turned out at the holder piece at the mount. As you look at the mont see if you can move any of your connections. Mine kept going back down enough that it wiggled loose. Start there and if nothing else take your wires out of the lock piece and put them on your depthfinder and see what happens.

Top
#11836272 - 09/18/16 09:23 PM Re: Hummingbird problems! [Re: BeardedBanker]
44 Diesel Online   content
TFF Team Angler

Registered: 12/25/12
Posts: 3427
Loc: Burleson,TX
Make sure it is wired with at least 16 gauge wire directly to battery with a 3 amp fuse or a dedicated fuse panel with graphs only. These new graphs good clean power.

Top
#11836582 - 09/19/16 07:29 AM Re: Hummingbird problems! [Re: BeardedBanker]
the skipper Online   content
Extreme Angler

Registered: 07/04/11
Posts: 1841
Loc: nederland, TX
Check your battery. What voltage is getting to the unit? If you are getting 12.8 at the battery and I would say anything below 12 at the unit I would run new wire directly to the battery. Also load test your battery and make sure it isn't going bad. Once I did have a problem in the power connection on a bird. Had to slightly bend the prongs out so they made good connection. Also put a small amount of electrical grease on the power connection prongs to keep them from getting corroded.

Top
#11836611 - 09/19/16 07:45 AM Re: Hummingbird problems! [Re: BeardedBanker]
McKinneyMike Online   content
Angler

Registered: 06/01/16
Posts: 251
Loc: McKinney, Texas
Use some DeOxit contact cleaner before applying any electrical grease to insure a good clean connection to start with unless it is brand new connection.

Top
#11837578 - 09/19/16 03:28 PM Re: Hummingbird problems! [Re: BeardedBanker]
Sinkey Online   content
Tidy Scoop

Registered: 08/04/06
Posts: 4094
Loc: Lewisville, TX.
None of the above!!!! I just had the same exact thing happen to me. Youll need to send it back to Hummingbird. The power button is going bad. They will fix it and send it back. I don't have the problem now.
_________________________

LAKE FORK MAFIA
www.grandebass.com
www.skeeterboats.com


Top
#11838058 - 09/19/16 07:14 PM Re: Hummingbird problems! [Re: NITRO Z8]
BeardedBanker Offline
Pro Angler

Registered: 01/06/13
Posts: 502
Loc: Queen City, TX
This was it! Thanks for everyone's response.

Top
#11838098 - 09/19/16 07:35 PM Re: Hummingbird problems! [Re: BeardedBanker]
2014NITROZ-7 Offline
Outdoorsman

Registered: 05/06/10
Posts: 179
Loc: Texas
Just asking,but what was it.

Top
#11838133 - 09/19/16 08:09 PM Re: Hummingbird problems! [Re: BeardedBanker]
west tex angler Offline
Angler

Registered: 05/01/14
Posts: 330
Loc: azle texas
I had same problem with a new 1198. problem was the power button.
_________________________
PB 9lbs 13oz

Top
#11838341 - 09/19/16 09:33 PM Re: Hummingbird problems! [Re: NITRO Z8]
BeardedBanker Offline
Pro Angler

Registered: 01/06/13
Posts: 502
Loc: Queen City, TX
Originally Posted By: NITRO Z8
Check your connections because mine turned out at the holder piece at the mount. As you look at the mont see if you can move any of your connections. Mine kept going back down enough that it wiggled loose. Start there and if nothing else take your wires out of the lock piece and put them on your depthfinder and see what happens.

Sorry, thought I was quoting it. It was this one.

Top
#11841148 - 09/21/16 12:10 PM Re: Hummingbird problems! [Re: BeardedBanker]
Corey Stokes Offline
Green Horn

Registered: 10/25/12
Posts: 12
I had a similar problem. Voltage checked good at the plug pins but not on screen through the unit. It would keep fluctuating and powering down. I ran a new wire to the battery. Problem solved.

Top
#11841170 - 09/21/16 12:20 PM Re: Hummingbird problems! [Re: BeardedBanker]
Battson34 Online   content
Outdoorsman

Registered: 06/04/14
Posts: 213
Loc: DFW
Nice of them to repair. Did they charge you?
_________________________
Brandon Battson
Battson Heat & Air LLC
817 851 8155
www.BattsonAC.com

www.MPackLures.com

www.KillerMotorsports.com

www.RoadrunnerCharters.com

Top



© 1998-2016 OUTDOOR SITES NETWORK all rights reserved USA and Worldwide