Main Menu
Advertisement
Affiliates
Advertisement
Newest Members
jfur, dburt2, AMG, ntxduffer, OKBlindHogg
108024 Registered Users
Top Posters
TexDawg 88644
hopalong 78895
Pilothawk 76394
John175® 67600
JDavis7873® 67390
FattyMcButterpants 60868
Derek 🐝 60289
Tritonman 57993
LoneStarSon® 54406
SkeeterRonnie 53367
facebook
Forum Stats
108024 Members
60 Forums
811381 Topics
10276267 Posts

Max Online: 36273 @ 01/23/13 02:34 PM
Topic Options
#11835453 - 09/18/16 12:48 PM Mercury fuel delivery issue??
Pantera III Offline
Outdoorsman

Registered: 11/07/10
Posts: 184
Loc: Pittsburg, TX
I have 99 optimax 200 hp. Thinking I could have a fuel delivery issue. Motor is bogging down at low rpm (1800- 2200). Runs great top end. Recently serviced and plugs and fuel filter replaced. Some time it seems to bog or hesitate worse than other times. I'm thinking possibly fuel pump? But bulb is staying firm. Any ideas greatly appreciated.


Edited by Pantera III (09/18/16 09:55 PM)

Top
#11835564 - 09/18/16 02:08 PM Re: Mercury fuel delivery issue?? [Re: Pantera III]
Pantera III Offline
Outdoorsman

Registered: 11/07/10
Posts: 184
Loc: Pittsburg, TX
Forgot to mention that full diagnostics was ran and everything checked out

Top
#11836343 - 09/18/16 09:57 PM Re: Mercury fuel delivery issue?? [Re: Pantera III]
Pantera III Offline
Outdoorsman

Registered: 11/07/10
Posts: 184
Loc: Pittsburg, TX
Ok, so after digging in the engine a little bit both high and low pressure fuel pumps seem to be operating correctly and no debris in housing.

Top
#11836808 - 09/19/16 09:33 AM Re: Mercury fuel delivery issue?? [Re: Pantera III]
Pantera III Offline
Outdoorsman

Registered: 11/07/10
Posts: 184
Loc: Pittsburg, TX
Any body?? Maybe coil pack?

Top
#11836919 - 09/19/16 10:31 AM Re: Mercury fuel delivery issue?? [Re: Pantera III]
lcbl75771 Offline
Extreme Angler

Registered: 03/20/03
Posts: 1311
Loc: Lindale, TX
I had issues for a long time with my motor bogging down. I never would have suspected it, but when the fuel pump was replaced the oblong gasket behind it got off and blocked the pulse hole a little. Needless to say I replaced a lot of stuff before I figured it out.

Top
#11845285 - 09/23/16 02:17 PM Re: Mercury fuel delivery issue?? [Re: Pantera III]
Pantera III Offline
Outdoorsman

Registered: 11/07/10
Posts: 184
Loc: Pittsburg, TX
Appears to have been a coil. Swapped out and running like a top now

Top



© 1998-2018 OUTDOOR SITES NETWORK all rights reserved USA and Worldwide