Main Menu
Advertisement
Affiliates
Advertisement
Newest Members
RushtonGregory, Bulletman77, thereason11, Lady808, PReaux
102720 Registered Users
Top Posters
TexDawg 82876
hopalong 74394
Pilothawk 73433
JDavis7873® 67377
FattyMcButterpants 60518
John175 ® 59892
Tritonman 56827
Derek 56416
SkeeterRonnie 52453
LoneStarSon® 52224
facebook
Forum Stats
102720 Members
61 Forums
859086 Topics
11270066 Posts

Max Online: 36273 @ 01/23/13 02:34 PM
Topic Options
#11815286 - 09/06/16 06:12 PM Baitcaster acting weird
Garett Offline
Outdoorsman

Registered: 07/18/13
Posts: 77
Hello everyone!
so i have a KVD quantum baitcaster and i love it. from time to time though it seems like its crapping out on me. yesterday i was throwing it all day and it was casting great distance. randomly near the end of my day it started to act like all the brakes were swtiched on. my long distance cast turns out to only go about 25 feet, no matter how hard i tried to cast it. i check my gears and nothing in them changed. this has happened before and randomly fixes itself over time but idk how.
_________________________
Follow our chase for the ultimate double digit Bassquatch
http://www.youtube.com/channel/UCEnug6v_rxgHusJzZebDY3Q

Top
#11815289 - 09/06/16 06:16 PM Re: Baitcaster acting weird [Re: Garett]
Mike_Soriano™ Offline
TFF Celebrity

Registered: 06/08/08
Posts: 5417
Loc: FORK
This happened to me with an accurist pt. Sometimes it would feel like the brakes were on 2 and sometimes like they were on 10. At random too. I think it's the logo


Edited by Mike_Soriano™ (09/06/16 06:17 PM)
_________________________
www.XciteBaits.com
www.Daiwa.com


Top
#11815552 - 09/06/16 09:11 PM Re: Baitcaster acting weird [Re: Garett]
ko bass attack 27 Online   content
TFF Celebrity

Registered: 01/05/12
Posts: 6333
Loc: Fritch, Tx. - Alba, Tx.
Maybe take it to someone that can clean it professionally.

Top
#11815614 - 09/06/16 09:41 PM Re: Baitcaster acting weird [Re: Garett]
1oldbassguy Offline
Outdoorsman

Registered: 08/04/16
Posts: 69
I had a Shimano Curado do something similar . I turned out to be a main bearing with a bad spot . On some cast's it would make a loud "chirping" sound and my distance would drop to 20-30 feet at best .Sent it for a repair and had them upgrade my bearings to ceramic and now it perfectly fine .
I would note that if you upgrade your bearings to any grade better than original , be extra careful on adjusting your settings . My first cast with ceramic bearings ended up in the worst backlash ever , had to cut out all the line and start over .

Top
#11816051 - 09/07/16 08:35 AM Re: Baitcaster acting weird [Re: Mike_Soriano™]
Nathan "Bull" Montgomery Offline
TFF Celebrity

Registered: 02/23/11
Posts: 5724
Loc: Fort Worth, Tx.
Originally Posted By: Mike_Soriano™
This happened to me with an accurist pt. Sometimes it would feel like the brakes were on 2 and sometimes like they were on 10. At random too. I think it's the logo


+1 on the logo not a fan of Quantums. Quality just isnt there.

Top
#11816661 - 09/07/16 03:12 PM Re: Baitcaster acting weird [Re: Nathan "Bull" Montgomery]
03svtsnakevert Online   content
Extreme Angler

Registered: 04/05/12
Posts: 2447
Loc: Copperas Cove, TX
Originally Posted By: Nathan "Bull" Montgomery
Originally Posted By: Mike_Soriano™
This happened to me with an accurist pt. Sometimes it would feel like the brakes were on 2 and sometimes like they were on 10. At random too. I think it's the logo


+1 on the logo not a fan of Quantums. Quality just isnt there.


Agreed!

Top
#11816827 - 09/07/16 05:10 PM Re: Baitcaster acting weird [Re: Garett]
bigbass94 Online   content
TFF Team Angler

Registered: 05/27/12
Posts: 3170
Loc: San Antonio, Texas
I had this happen to me multiple times with my Abu Garcia's. One day it didn't work and then the next it was fine... weirdest thing ever. I even had it happen to me right after having the reels cleaned. That's why I switched to Shimano. I was tired of having problems with my Abu's. Haven't had the problem since I switched to Shimano. I don't like bashing other brands but the quality is lacking in some of the high dollar Abu's.


Edited by bigbass94 (09/07/16 05:10 PM)
_________________________
"If people concentrated on the really important things in life, there'd be a shortage of fishing poles." - Doug Larson

"That was like watching the birth of Jesus!"-Urban Fisher

Top
#11816910 - 09/07/16 06:09 PM Re: Baitcaster acting weird [Re: Garett]
KVS Online   content
TFF Team Angler

Registered: 06/22/08
Posts: 3330
Loc: Burleson, Tx
PM sent
_________________________
Kevin Smith
www.ShamrockRods.com
www.Facebook.com/ShamrockRods


Top
#11816934 - 09/07/16 06:27 PM Re: Baitcaster acting weird [Re: Garett]
Bassalong Offline
Pro Angler

Registered: 02/08/05
Posts: 767
Loc: Iowa
Surely this is not it but....sometimes if your spool is real loose and you are running a full spool line can get caught between your spool edge and the reel frame. Line can also get caught by your lure holding loop just ahead of the forgrip of your reel.

Top
#11816940 - 09/07/16 06:29 PM Re: Baitcaster acting weird [Re: bigbass94]
SteezMacQueen Online   happy
TFF Team Angler

Registered: 11/02/14
Posts: 3045
Loc: Red Oak, Galveston, and Pagosa...
Originally Posted By: bigbass94
I had this happen to me multiple times with my Abu Garcia's. One day it didn't work and then the next it was fine... weirdest thing ever. I even had it happen to me right after having the reels cleaned. That's why I switched to Shimano. I was tired of having problems with my Abu's. Haven't had the problem since I switched to Shimano. I don't like bashing other brands but the quality is lacking in some of the high dollar Abu's.


I have a Steez with that "gremlin" right now. Turns out the neodymium magnet ring is poorly glued into place and the polarization of the magnetic force changes as I turn the dial. "0" is all braking force. if I change it to "5", its normal for a few casts...then "5" is maximum braking force...move to "10" ...and ....well....you get it. Back to "0".....and again. You get it.

I have to send that one back for service as I have no idea what is the proper radial position of the ring magnet is in relation to its retainer. It also happened after I cleaned it with rubbing alcohol. I probably soaked the glue with the stuff and released the glues hold on it.

You might check for something similar if it has magnetic brakes. You might check for sticking "clickers" if it has centrifugal brakes.
_________________________
Daiwa
Megabass
Lews



Top



© 1998-2016 OUTDOOR SITES NETWORK all rights reserved USA and Worldwide