Main Menu
Advertisement
Affiliates
Advertisement
Newest Members
jwhit88, Fisherman954, Mud Liger, Joe111, EL Mike
102702 Registered Users
Top Posters
TexDawg 82848
hopalong 74355
Pilothawk 73410
JDavis7873® 67377
FattyMcButterpants 60518
John175 ® 59859
Tritonman 56813
Derek 56400
SkeeterRonnie 52446
LoneStarSon® 52210
facebook
Forum Stats
102702 Members
61 Forums
858694 Topics
11264523 Posts

Max Online: 36273 @ 01/23/13 02:34 PM
Page 1 of 2 1 2 >
Topic Options
#11750158 - 07/30/16 01:45 PM Engine alarm going off on 2009 Merc 150 EFI
burghman Offline
Outdoorsman

Registered: 11/12/07
Posts: 33
Loc: Flower Mound, TX
My alarm intermittently goes off when I'm on the lake. It has happened when I've been running 3/4 throttle but it also has happened when going slow in a no wake zone. The trim is low so I don't think that is the problem. The water pump appears to be working as well since it's always spitting water. I'm looking for a reputable place around Denton County to check it out Thanks.

Top
#11750200 - 07/30/16 02:34 PM Re: Engine alarm going off on 2009 Merc 150 EFI [Re: burghman]
Anchorman Offline
Extreme Angler

Registered: 03/02/15
Posts: 1172
Loc: Small Town NE Texas
Some of the slightly older mercs were bad about the oil reservoir caps cracking. If my memory is correct it's the small one on the front of the engine. Check that. That's a cheap easy fix it that is the problem. I'm not 100% sure which res cap it is so better check both of them. I just remember a cracked oil reservoir cap causing that symptom on many mercs. Good luck


Edited by Anchorman (07/30/16 02:35 PM)
_________________________
If it ain't yours don't mess with it!
Need a friendly place to talk hunting? www.talkhunting.com


Top
#11751202 - 07/31/16 08:54 AM Re: Engine alarm going off on 2009 Merc 150 EFI [Re: burghman]
Muzzlebrake Offline
Extreme Angler

Registered: 12/26/14
Posts: 1004
Loc: Euless
Is it beeps or a steady squeal?
_________________________
Infidel and proud of it.

From Genesis: "And God promised men that good and obedient wives would be found in all corners of the earth."

Then He made the earth round...and He laughed and laughed and laughed!

Top
#11751678 - 07/31/16 02:47 PM Re: Engine alarm going off on 2009 Merc 150 EFI [Re: burghman]
gary purdy Offline
TFF Guru

Registered: 05/24/03
Posts: 10515
Loc: Littlefield Tx & Lake A. H. US...
Oil level sensor in the motor mounted oil reservoir. Screen may need cleaned in the boat mounted main oil tank. 4 beeps can be water in the fuel.
_________________________
“The world will not be destroyed by those who do evil, but by those who watch them without doing anything” GOD IS GOOD

Top
#11751870 - 07/31/16 04:35 PM Re: Engine alarm going off on 2009 Merc 150 EFI [Re: Anchorman]
Dude Lebowski Offline
Angler

Registered: 01/04/11
Posts: 455
Loc: Spring, TX
Originally Posted By: Anchorman
Some of the slightly older mercs were bad about the oil reservoir caps cracking. If my memory is correct it's the small one on the front of the engine. Check that. That's a cheap easy fix it that is the problem. I'm not 100% sure which res cap it is so better check both of them. I just remember a cracked oil reservoir cap causing that symptom on many mercs. Good luck

It is usually the oil reservoir on the outboard. I also had an alarm module go bad on a 150 EFI before. It was a constant alarm every time you turned the key on. It started out intermittently.
_________________________

Top
#11756399 - 08/03/16 08:51 AM Re: Engine alarm going off on 2009 Merc 150 EFI [Re: burghman]
buggsboy Offline
Outdoorsman

Registered: 07/22/11
Posts: 195
Loc: Carthage, Tx/Lake Fork
I have the same model motor. In my case it was 4 beeps every few minutes. It was a problem with the oil level sensor in the oil reservoir under the engine cowling.

Top
#11756409 - 08/03/16 08:57 AM Re: Engine alarm going off on 2009 Merc 150 EFI [Re: burghman]
Anchorman Offline
Extreme Angler

Registered: 03/02/15
Posts: 1172
Loc: Small Town NE Texas
Yep that is what I was thinking. The cap has the oil level sensor built in to it. Easy to replace. Hopefully that is all it is.
_________________________
If it ain't yours don't mess with it!
Need a friendly place to talk hunting? www.talkhunting.com


Top
#11773264 - 08/12/16 10:32 AM Re: Engine alarm going off on 2009 Merc 150 EFI [Re: burghman]
burghman Offline
Outdoorsman

Registered: 11/12/07
Posts: 33
Loc: Flower Mound, TX
It's a steady squeal.

Top
#11773619 - 08/12/16 01:48 PM Re: Engine alarm going off on 2009 Merc 150 EFI [Re: burghman]
buggsboy Offline
Outdoorsman

Registered: 07/22/11
Posts: 195
Loc: Carthage, Tx/Lake Fork
I wouldn't run it again with that steady squeal. I believe that is a more serious alarm. Identify problem before running again.

Top
#11774715 - 08/13/16 09:40 AM Re: Engine alarm going off on 2009 Merc 150 EFI [Re: burghman]
gary purdy Offline
TFF Guru

Registered: 05/24/03
Posts: 10515
Loc: Littlefield Tx & Lake A. H. US...
Solid tone is over heat on 2 strokes
_________________________
“The world will not be destroyed by those who do evil, but by those who watch them without doing anything” GOD IS GOOD

Top
#11774754 - 08/13/16 10:10 AM Re: Engine alarm going off on 2009 Merc 150 EFI [Re: burghman]
burghman Offline
Outdoorsman

Registered: 11/12/07
Posts: 33
Loc: Flower Mound, TX
Any recommendations on where to take it for a once over in/around Denton County?

Top
#11774859 - 08/13/16 11:51 AM Re: Engine alarm going off on 2009 Merc 150 EFI [Re: burghman]
bronco71 Offline
Extreme Angler

Registered: 02/05/06
Posts: 1049
Loc: Farmers Branch/Sulphur Bluff
possibly t-stats or poppet valve?

Top
#11776288 - 08/14/16 10:59 AM Re: Engine alarm going off on 2009 Merc 150 EFI [Re: burghman]
gary purdy Offline
TFF Guru

Registered: 05/24/03
Posts: 10515
Loc: Littlefield Tx & Lake A. H. US...
Certified shop just installed this last week. Told customer he had other problems. I decided to just check it.



Edited by gary purdy (08/14/16 11:02 AM)
_________________________
“The world will not be destroyed by those who do evil, but by those who watch them without doing anything” GOD IS GOOD

Top
#11776480 - 08/14/16 01:42 PM Re: Engine alarm going off on 2009 Merc 150 EFI [Re: burghman]
bronco71 Offline
Extreme Angler

Registered: 02/05/06
Posts: 1049
Loc: Farmers Branch/Sulphur Bluff
Wow, never seen one turned both ways before! Do you think they turned it the wrong way when installing it?

Top
#11777015 - 08/14/16 07:31 PM Re: Engine alarm going off on 2009 Merc 150 EFI [Re: burghman]
Muzzlebrake Offline
Extreme Angler

Registered: 12/26/14
Posts: 1004
Loc: Euless
That's crazy. No way that could pump properly.
_________________________
Infidel and proud of it.

From Genesis: "And God promised men that good and obedient wives would be found in all corners of the earth."

Then He made the earth round...and He laughed and laughed and laughed!

Top
Page 1 of 2 1 2 >



© 1998-2016 OUTDOOR SITES NETWORK all rights reserved USA and Worldwide