Main Menu
Advertisement
Affiliates
Advertisement
Newest Members
Hooter Magruder, modset, Sjenno15, KI Bassin, pjeffrey
104443 Registered Users
Top Posters
TexDawg 84488
hopalong 76574
Pilothawk 74348
JDavis7873® 67382
John175 ® 62508
FattyMcButterpants 60659
Tritonman 57362
Derek 57335
SkeeterRonnie 52787
LoneStarSon® 52658
facebook
Forum Stats
104443 Members
60 Forums
787024 Topics
9949694 Posts

Max Online: 36273 @ 01/23/13 02:34 PM
Topic Options
#11663988 - 06/13/16 10:54 AM 1998 Merc. 175 EFI Repair ?
propman Offline
Angler

Registered: 04/06/10
Posts: 433
Loc: Pilot Point, TX
I am in need of some work to be done on my usually reliable motor. It started up fine in the AM last Friday at Lake Ray Roberts Jordon Park and we ran to Cate's Point but couldn't get it started and running again and had to be towed back to Jordon Park. Thanks much to the good Samaritan who gave us the tow. He told us that when it turned over, and tried to fire, that black smoke came out of it. It fired a couple of times but as soon as you got off the hot foot it would stall out and not start again. Thought it might be flooded but even resting for 15 min didn't help. I even changed batteries to try and get it started but even that didn't help. When I got it home I took the cover off again, drained the gas/water/debris filter then pumped the bulb to refill it, but then noticed fuel running down behind what I assume is the air filter. Don't know anything about motors and the Mercury Book I have that came with the motor doesn't help me much. I live in Pilot Point and have used Bear Marine in the past, but recently I had to re-do some work they had supposedly done for me, so I am not too sure I want to go back there again, although, other than this last time of using them their work has been super. I would like a recommendation for a different Mercury motor repair place as close to Pilot Point as possible. Thanks.

Top
#11664285 - 06/13/16 12:33 PM Re: 1998 Merc. 175 EFI Repair ? [Re: propman]
Brazos Bass Cat Offline
TFF Team Angler

Registered: 04/17/06
Posts: 3731
Loc: Benbrook/Granbury/Whitney/Stil...
Patterson Marine is in Hurst but worth the drive. He is a pro with the mercs.
_________________________

Team Pro-Cull

Top
#11664290 - 06/13/16 12:34 PM Re: 1998 Merc. 175 EFI Repair ? [Re: propman]
David Burton Offline
Extreme Angler

Registered: 07/14/11
Posts: 1695
Loc: McKinney, TX
Check the plugs for fouling and replace. If it goes, easy fix. But you'll want to find out why it isn't burning fuel efficiently. Fuel draining is not a good sign though!

Also, if you are talking about the canister filter on the starboard side of the motor, that is a water separator filter. There should be a sensor that screws into the bottom, it may have cracked, and replacing the filter could fix your problem there!

There are a number of good folks out there that can get you taken care of.

Good luck!


Edited by David Burton (06/13/16 12:41 PM)
Edit Reason: Filter note
_________________________
David Burton
2015 Skeeter FX 21


Top



© 1998-2017 OUTDOOR SITES NETWORK all rights reserved USA and Worldwide