Main Menu
Advertisement
Affiliates
Advertisement
Newest Members
John garrison, TSquared, mikemc877, ND fishin, CapAmerFisher42
104505 Registered Users
Top Posters
TexDawg 84540
hopalong 76666
Pilothawk 74396
JDavis7873® 67382
John175 ® 62570
FattyMcButterpants 60661
Derek 57380
Tritonman 57374
SkeeterRonnie 52820
LoneStarSon® 52664
facebook
Forum Stats
104505 Members
60 Forums
787592 Topics
9957471 Posts

Max Online: 36273 @ 01/23/13 02:34 PM
Topic Options
#11651935 - 06/07/16 10:02 AM 09 21 I Class livewell pumps
GeoFisher Offline
Pro Angler

Registered: 06/26/13
Posts: 555
Ok, I have a panel on the left side of my console that controls all the livewells, bilges etc. All of the buttons are "push button" with orange indicator lights that indicate when "on". The port pumps quit on me a couple weeks ago and the orange lights on the port fill button now "blink" ALL THE TIME. The only way to get them to turn off is to unplug the single junction box behind the console. That one junction controls EVERYTHING on the left side of console (bilges, horn, starboard pumps) along with the port side pumps (about 8 buttons). Anyone have a quick diagnosis? What should I try first? I am quite the novice when it comes to anything electrical. Appreciate any advice.Thanks.
_________________________
Aren't they all "reaction" bites?

Top
#11661918 - 06/12/16 06:23 AM Re: 09 21 I Class livewell pumps [Re: GeoFisher]
Txmedic033 Offline
TFF Team Angler

Registered: 08/13/13
Posts: 3968
Loc: Longview, Tx
Check the fuse and check the pump. If the fuse is good, then you probably need to replace the pump. That is very easy to do and it only has a positive and a negative wire. If you own a boat and don't want to spend a bundle paying someone else to work on it, you better learn electrical. It's not that bad once you get used to it. I have pretty much rewired my entire boat since I got it.

Top
#11662703 - 06/12/16 05:07 PM Re: 09 21 I Class livewell pumps [Re: GeoFisher]
El Skeeter Offline
Angler

Registered: 06/22/12
Posts: 433
Loc: Kissimmee,FL
Try holding "ON" button in for 5-10 seconds to reset.

Top



© 1998-2017 OUTDOOR SITES NETWORK all rights reserved USA and Worldwide