Main Menu
Advertisement
Affiliates
Advertisement
Newest Members
Mdrr, Brazos king, Jiggin71, Michal76, Deep_STX_Carper
105456 Registered Users
Top Posters
TexDawg 85627
hopalong 78097
Pilothawk 74941
JDavis7873® 67382
John175 ® 64369
FattyMcButterpants 60667
Derek 🐝 58036
Tritonman 57517
LoneStarSon® 53062
SkeeterRonnie 52941
facebook
Forum Stats
105456 Members
60 Forums
798470 Topics
10092656 Posts

Max Online: 36273 @ 01/23/13 02:34 PM
Topic Options
#11625235 - 05/25/16 10:00 AM I Pilot Questions
lonestar Offline
Angler

Registered: 07/03/01
Posts: 472
Loc: Cleburne, TX
I have a 24V I Pilot and when using, it will sometimes not respond to remote. When trying to move it sometimes will not turn or may not turn off or on when trying to move. I can be standing right next to motor or at back of boat, doesn't matter. Also, some times when it is on anchor or spot lock it will just turn off and I lose my spot. Brand new batteries on motor. Any advice on what it might be?

Top
#11625388 - 05/25/16 11:01 AM Re: I Pilot Questions [Re: lonestar]
Capt Craig Offline
Extreme Angler

Registered: 08/25/09
Posts: 1261
Loc: Richland-Chambers
I have had the same thing happen from time to time. Even after putting in a new battery. It could be a software issue, but I have replaced a new battery with another new battery and had the problem resolve. Also, I remove the battery on the water and then just put it back in to resolve it.
_________________________
Capt. Craig Copeland
Licensed by the US Coast Guard

2013 Nautic Star 2110 Shallow Bay Boat
Humminbird HELIX 12 CHIRP MEGA SI GPS G2N
Nautic Star Boats Pro Staff (nauticstarboats.com)
Redneck Fish'n Jigs Pro Staff (redneckfishn.com)

Top
#11625518 - 05/25/16 11:45 AM Re: I Pilot Questions [Re: Capt Craig]
TCK73 Online   content
Extreme Angler

Registered: 03/26/15
Posts: 2737
Loc: Jack County
Mine does this a lot. I hate it, and it can get you in a bind while maneuvering in tight quarters. I'm debating going to a Xi5

Top
#11625636 - 05/25/16 12:21 PM Re: I Pilot Questions [Re: lonestar]
44 Diesel Online   content
TFF Team Angler

Registered: 12/25/12
Posts: 4387
Loc: Burleson,TX
Might try to make sure the battery is making good contact with the contacts inside the remote. Is this the regular I pilot or link?

Top
#11625682 - 05/25/16 12:36 PM Re: I Pilot Questions [Re: lonestar]
UJC Offline
Extreme Angler

Registered: 01/12/07
Posts: 1948
Loc: Plano, TX
This might help. The Terrova takes a 2450 lithium battery BUT not all batteries are created equal. I had intermittent problems too, swapped new batteries, removed battery/place right back in on the water to make it work, etc. Then after some research, I got the 2450N. It is a little complicated but read this. I'd suggest reading post 18 and click the OPs 'here' for a full description.

I got my 'N' at Radio Shack.
_________________________
LIVE PURPLE LOVE GOLD
Jimmy

Top
#11625707 - 05/25/16 12:45 PM Re: I Pilot Questions [Re: lonestar]
buton Offline
Extreme Angler

Registered: 05/28/10
Posts: 1401
Loc: Cypress,Tx
my ipilot has work without problems. just give a call to humminbird they have some good customer service.
_________________________

Top
#11625857 - 05/25/16 01:45 PM Re: I Pilot Questions [Re: lonestar]
Bobby Milam Offline
Extreme Angler

Registered: 07/13/14
Posts: 2611
Loc: Arlington
I had intermittent problems with mine. Usually it was something interfering. I upgraded to the link and it resolved my problem. I never had it happen up close to the unit though. I'd contact Minn Kota

Top
#11626730 - 05/25/16 08:04 PM Re: I Pilot Questions [Re: lonestar]
lonestar Offline
Angler

Registered: 07/03/01
Posts: 472
Loc: Cleburne, TX
It is a regular I Pilot, not link. I carry an extra battery for remote but have not changed it recently. Need to look for a "N" and try that. Thanks for the replies!

Top



© 1998-2017 OUTDOOR SITES NETWORK all rights reserved USA and Worldwide