Main Menu
Advertisement
Affiliates
Advertisement
Newest Members
MinMirny, lakefork15, Littledog, chatterbait10, DeekBrazo
106373 Registered Users
Top Posters
TexDawg 86933
hopalong 78792
Pilothawk 75581
JDavis7873® 67385
John175 ® 65737
FattyMcButterpants 60793
Derek 🐝 58869
Tritonman 57722
LoneStarSon® 53710
SkeeterRonnie 53103
facebook
Forum Stats
106373 Members
61 Forums
812048 Topics
10252279 Posts

Max Online: 36273 @ 01/23/13 02:34 PM
Topic Options
#11618239 - 05/22/16 01:27 PM Mercury xri 150 problems
BassMan922 Offline
Angler

Registered: 04/22/10
Posts: 304
Loc: Midland, Tx
It's a 96 Mercury xri 150 efi. Runs great on low end and high end but starting and starting it after running is next to impossible. I puffs serious white smoke every time but once started it runs like a dream. Any help would be much appreciated.
_________________________
One more cast for Mr.Big!!!!




Top
#11618267 - 05/22/16 01:48 PM Re: Mercury xri 150 problems [Re: BassMan922]
GIG'EM AGGIES Offline
Extreme Angler

Registered: 05/14/14
Posts: 2017
Loc: texas
Bassman, what I found with mine was the motor had to be level to start good. If it was trimmed up even just a little it was hard to start. I was told it had something to do with the float system but don't know that for sure. I know that once I found this out my Merc would fire right up every time usually without even choking it. Hope this helps.
_________________________
"Sometimes there just aren't enough rocks"
Forest Gump

Top
#11618521 - 05/22/16 04:11 PM Re: Mercury xri 150 problems [Re: BassMan922]
gary purdy Offline
TFF Guru

Registered: 05/24/03
Posts: 11216
Loc: Littlefield Tx & Lake A. H. US...
Mecury`s oil system works off of pressure from the crankcase via a pulse valve and if the bleed in the pulse valve stops up it will do just that. Causes the tank to maintain too much pressure when motor is turned off.
_________________________
The world will not be destroyed by those who do evil, but by those who watch them without doing anything. Remember what He has done and remember that He is not done yet!-- GOD IS GOOD

Top
#11618581 - 05/22/16 05:05 PM Re: Mercury xri 150 problems [Re: BassMan922]
BassMan922 Offline
Angler

Registered: 04/22/10
Posts: 304
Loc: Midland, Tx
So is it the bleed of or do I need to change the pulse valve?
_________________________
One more cast for Mr.Big!!!!




Top
#11618650 - 05/22/16 05:55 PM Re: Mercury xri 150 problems [Re: BassMan922]
TLW Offline
Extreme Angler

Registered: 11/16/06
Posts: 2236
Loc: ft worth
sounds like MIGHT have something ta do with tha enrichner circuit... trim it ALL tha way in when ya start... see if that helps at all.

Top
#11618835 - 05/22/16 07:12 PM Re: Mercury xri 150 problems [Re: TLW]
BassMan922 Offline
Angler

Registered: 04/22/10
Posts: 304
Loc: Midland, Tx
Originally Posted By: TLW
sounds like MIGHT have something ta do with tha enrichner circuit... trim it ALL tha way in when ya start... see if that helps at all.



I have done that and the problem persists
_________________________
One more cast for Mr.Big!!!!




Top



© 1998-2017 OUTDOOR SITES NETWORK all rights reserved USA and Worldwide