Main Menu
Advertisement
Affiliates
Advertisement
Newest Members
moparpartsguy, Skeeter21son, drm42756, Adam Foster, George Perkins
103975 Registered Users
Top Posters
TexDawg 84216
hopalong 75944
Pilothawk 74189
JDavis7873® 67380
John175 ® 62188
FattyMcButterpants 60645
Tritonman 57318
Derek 57163
SkeeterRonnie 52704
LoneStarSon® 52586
facebook
Forum Stats
103975 Members
61 Forums
835170 Topics
11919260 Posts

Max Online: 36273 @ 01/23/13 02:34 PM
Topic Options
#11595605 - 05/10/16 09:52 PM tilt and trim issue
Bobby Milam Online   content
Extreme Angler

Registered: 07/13/14
Posts: 2248
Loc: Arlington
I have a 94 Mercury 115. Tilt and trim has been working great. Today, I was surprised by a wake boat that passed in front of me and hit his wake before I could slow down. It sent the entire boat airborne. Not just a little bit, it shot straight up like a rocket and landed on his other wake. The engine was the first thing to hit the water and we hit hard. The motor started acting up afterwards and did not want to get on plane. You could also feel a jerking coming from the back of the boat. I nursed it back to the trailer and when I tilted the motor and drove onto the trailer, not only did I not have the power to fully drive on, the engine would pull the tilt back down every time that I tried. The t/t functions fine up and down and holds it's own weight. I assume that the weight of the boat crashing back into the water has done something to the fluid inside, maybe blowing a seal or something. I didn't see any signs of fluid leaking upon getting it out of the water.

What kind of fluid do they take and how hard are they to fill properly?

Top
#11595789 - 05/10/16 10:53 PM Re: tilt and trim issue [Re: Bobby Milam]
Bobby Milam Online   content
Extreme Angler

Registered: 07/13/14
Posts: 2248
Loc: Arlington
Never mind I found the info.

Top



© 1998-2017 OUTDOOR SITES NETWORK all rights reserved USA and Worldwide