Main Menu
Advertisement
Affiliates
Advertisement
Newest Members
moparpartsguy, Skeeter21son, drm42756, Adam Foster, George Perkins
103975 Registered Users
Top Posters
TexDawg 84216
hopalong 75951
Pilothawk 74191
JDavis7873® 67380
John175 ® 62190
FattyMcButterpants 60645
Tritonman 57318
Derek 57163
SkeeterRonnie 52704
LoneStarSon® 52586
facebook
Forum Stats
103975 Members
61 Forums
785191 Topics
9919434 Posts

Max Online: 36273 @ 01/23/13 02:34 PM
Topic Options
#11561085 - 04/23/16 04:16 PM help with power pole blade installation
SK1 Offline
Outdoorsman

Registered: 05/27/14
Posts: 232
Just installed brand new 10ft blade on the skeeter only pole goes down but won't retract . I'm thinking bad pump? Anybody else had this to happen? Did the prime and checked all fittings for tightnest. Any suggestions/help?

Top
#11561108 - 04/23/16 04:42 PM Re: help with power pole blade installation [Re: SK1]
Clark3 Offline
Pro Angler

Registered: 01/22/12
Posts: 554
Loc: Lake fork/Fort Worth, TX
Originally Posted By: SK1
Just installed brand new 10ft blade on the skeeter only pole goes down but won't retract . I'm thinking bad pump? Anybody else had this to happen? Did the prime and checked all fittings for tightnest. Any suggestions/help?


Are you sure the hoses are hooked up to their correct respective ports? Did you use the whole quart of oil supplied?

Top
#11561124 - 04/23/16 04:53 PM Re: help with power pole blade installation [Re: SK1]
SK1 Offline
Outdoorsman

Registered: 05/27/14
Posts: 232
Yes and yes

Top
#11561149 - 04/23/16 05:17 PM Re: help with power pole blade installation [Re: SK1]
Flippin-Out Offline
Extreme Angler

Registered: 02/25/15
Posts: 1627
Loc: Magnolia, TX
When you attempt to retract, do you hear the electric motor (that powers the pump) run? If it's not running, it's obviously not going to retract.

I assume you're pressing the up/down button on top of the motor housing (vs. a remote button)?

You may be able to more easily diagnose the issue if you remove the bolt in the Power Pole for the moving end of the hydraulic actuator. This will let the ram extend and retract without physically moving the Power Pole itself. It will also eliminate the unlikely case of some part mechanically binding. The pumps don't really have a lot of torque, so if something in binding badly, it may not retract.

I don't know if you have cycled the pump very many times or not. Sometimes it can take quite a few up/down cycles to properly prime the system. Remember it will almost always go DOWN due to gravity (even the very first time), but fail to retract until after the system is primed. Do at least 10 cycles before you declare it broken. Let us know....


Edited by Flippin-Out (04/23/16 05:18 PM)

Top
#11561159 - 04/23/16 05:20 PM Re: help with power pole blade installation [Re: SK1]
Andrew Y'Barbo Online   content
Extreme Angler

Registered: 06/25/12
Posts: 1217
Loc: Lufkin Texas
Call me and I might can help. Customer ran into a problem like this. 936 465 5551

Top
#11573486 - 04/29/16 01:04 PM Re: help with power pole blade installation [Re: SK1]
SK1 Offline
Outdoorsman

Registered: 05/27/14
Posts: 232
Follow up to initial post, powerpole promptly sent out another pump and it works great.Powerpole has great customer service.Problem solved.

Top
#11573747 - 04/29/16 02:59 PM Re: help with power pole blade installation [Re: SK1]
Pitdad Offline
Angler

Registered: 01/18/10
Posts: 316
That sounds messy...
_________________________

Top



© 1998-2017 OUTDOOR SITES NETWORK all rights reserved USA and Worldwide