Main Menu
Advertisement
Affiliates
Advertisement
Newest Members
Texasbuckeye, tmd11111, Jackmeg2011, js1, Greenair
104528 Registered Users
Top Posters
TexDawg 84565
hopalong 76757
Pilothawk 74407
JDavis7873® 67382
John175 ® 62613
FattyMcButterpants 60661
Derek 57402
Tritonman 57377
SkeeterRonnie 52829
LoneStarSon® 52672
facebook
Forum Stats
104528 Members
60 Forums
837862 Topics
11960859 Posts

Max Online: 36273 @ 01/23/13 02:34 PM
Topic Options
#11550975 - 04/18/16 06:31 PM I-pilot power trouble Need help
Scotty P Online   content
Pro Angler

Registered: 07/17/06
Posts: 754
Loc: Plano
When using my foot control for my I-pilot, as soon as I touch the on button, it stays on and will not turn off until I stow the motor. The remote will not work because it detects the motor is already running.
Any idea what to do? It is only 9 months old.
Thank you,
Scotty

Top
#11551069 - 04/18/16 07:26 PM Re: I-pilot power trouble Need help [Re: Scotty P]
Bob Landry Offline
Extreme Angler

Registered: 08/10/11
Posts: 2389
Loc: Austin, Tx
Start by disconnecting the foot control. That will tell you if that is the problem or not. Otherwise, it's probably the control head. I'm sure there is an SCR that controls motor operation and like any other solid state device, I could short once turned on keeping the motor running.
_________________________
2015 Seaark 1872 MV CC Etec-90
Two Helix 12 CHIRP SI's, , MinnKota Riptide ST80/i-pilot Link, Bob's Hydraulic

Bitter Gun Owner
Bitter Clinger
Armed Infidel

Top



© 1998-2017 OUTDOOR SITES NETWORK all rights reserved USA and Worldwide