Main Menu
Newest Members
Yeagerbombs, Clark225, neal shaffer jr, errold, 1 Papa D
102325 Registered Users
Top Posters
TexDawg 82168
hopalong 73414
Pilothawk 72811
JDavis7873® 67374
FattyMcButterpants 60428
John175 ® 59617
Tritonman 56538
Derek 56119
SkeeterRonnie 52392
LoneStarSon® 51978
Forum Stats
102325 Members
60 Forums
853316 Topics
11190948 Posts

Max Online: 36273 @ 01/23/13 02:34 PM
Topic Options
#11537375 - 04/12/16 01:57 PM Speedometer inop???
RickS Offline

Registered: 08/08/13
Posts: 183
Loc: Santa Fe NM
I have a 97 Nitro 800 with a mercury 150xr6. My speedometer hasn't been working. In the past there is a pickup hole on my lower unit that has gotten plugged. Anyway I cleaned it and still didn't help. I'm wondering if it's the actual speedometer itself. It's actually stuck at 20 mph. How do I bench test it? Is there a water pressure specification for the speedometer? Thanks for any input!

#11537407 - 04/12/16 02:12 PM Re: Speedometer inop??? [Re: RickS]
steve@scp Online   content
TFF Celebrity

Registered: 08/25/06
Posts: 6610
Loc: Quitman,Tx
just my input.

pull the gauge out and throw it away. instal a gauge like an engine water pressure gauge. smile

but.. to "test" it.. pull the hose off the back of the gauge and see if the needle drops to zero.

#11538050 - 04/12/16 05:51 PM Re: Speedometer inop??? [Re: RickS]
centexChamp92 Offline
Green Horn

Registered: 05/21/13
Posts: 18
Same thing happened with my '92. Each gauge would stop over time and eventually i just replaced them. They were either all stuck or wouldn't be accurate. Solid advice above.


© 1998-2016 OUTDOOR SITES NETWORK all rights reserved USA and Worldwide