Main Menu
Advertisement
Affiliates
Advertisement
Newest Members
abowhunter123, txdude350, TwoSpeedTony, Kurt L, woodtick84
103559 Registered Users
Top Posters
TexDawg 84017
hopalong 75502
Pilothawk 74024
JDavis7873® 67380
John175 ® 61835
FattyMcButterpants 60638
Tritonman 57282
Derek 57021
SkeeterRonnie 52609
LoneStarSon® 52537
facebook
Forum Stats
103559 Members
61 Forums
869250 Topics
11405903 Posts

Max Online: 36273 @ 01/23/13 02:34 PM
Topic Options
#11537375 - 04/12/16 01:57 PM Speedometer inop???
RickS Offline
Outdoorsman

Registered: 08/08/13
Posts: 185
Loc: Santa Fe NM
I have a 97 Nitro 800 with a mercury 150xr6. My speedometer hasn't been working. In the past there is a pickup hole on my lower unit that has gotten plugged. Anyway I cleaned it and still didn't help. I'm wondering if it's the actual speedometer itself. It's actually stuck at 20 mph. How do I bench test it? Is there a water pressure specification for the speedometer? Thanks for any input!

Top
#11537407 - 04/12/16 02:12 PM Re: Speedometer inop??? [Re: RickS]
steve@scp Offline
TFF Celebrity

Registered: 08/25/06
Posts: 6647
Loc: Quitman,Tx
just my input.

pull the gauge out and throw it away. instal a gauge like an engine water pressure gauge. smile


but.. to "test" it.. pull the hose off the back of the gauge and see if the needle drops to zero.
_________________________
www.hydrodynamics-usa.com
903-763-5225





Top
#11538050 - 04/12/16 05:51 PM Re: Speedometer inop??? [Re: RickS]
centexChamp92 Offline
Green Horn

Registered: 05/21/13
Posts: 18
Same thing happened with my '92. Each gauge would stop over time and eventually i just replaced them. They were either all stuck or wouldn't be accurate. Solid advice above.

Top



© 1998-2016 OUTDOOR SITES NETWORK all rights reserved USA and Worldwide