Main Menu
Advertisement
Affiliates
Advertisement
Newest Members
firemom2bay, Clynn5, Wildman1, TheMattador, Ray1216
108003 Registered Users
Top Posters
TexDawg 88603
hopalong 78895
Pilothawk 76390
John175® 67560
JDavis7873® 67390
FattyMcButterpants 60868
Derek 🐝 60244
Tritonman 57988
LoneStarSon® 54395
SkeeterRonnie 53365
facebook
Forum Stats
108003 Members
60 Forums
811014 Topics
10271454 Posts

Max Online: 36273 @ 01/23/13 02:34 PM
Topic Options
#11504115 - 03/27/16 11:49 AM Minkota 4 bank charger
forkduc Online   content
TFF Guru

Registered: 03/28/07
Posts: 11703
Loc: Plano,Texas
2 years old. Had new cranking battery installed. Took boat to Fork and plugged in all night. Morning, 1 light showing green and red on battery 3. Took to shop and had load tested,battery 3 was dead,replaced it. Plugged charger in an amber and green on #3,other nada. Any ideas? I'm thinking bad charger.

Top
#11506066 - 03/28/16 11:36 AM Re: Minkota 4 bank charger [Re: forkduc]
forkduc Online   content
TFF Guru

Registered: 03/28/07
Posts: 11703
Loc: Plano,Texas
So,I'm the only one to have had this problem?

Top
#11506604 - 03/28/16 03:19 PM Re: Minkota 4 bank charger [Re: forkduc]
Allan W Offline
Extreme Angler

Registered: 09/04/09
Posts: 1193
Loc: EM Lake
Unplug it and plug it back in. I bet it will only show the green light.

Top
#11507451 - 03/28/16 09:26 PM Re: Minkota 4 bank charger [Re: forkduc]
jfdawson Offline
Pro Angler

Registered: 06/21/05
Posts: 930
Loc: Frisco, Tx / Atlanta, Tx
Skip, assume you have MK precision 460? Do you have th correct battery type selected? The 460 has the ability to charge AGM, Gel, or flooded cell. You need to make sure you match the correct type Otherwise you can burn (overheat ) the battery. Might not be your issue, but worth checking.

Jeff

Top
#11508121 - 03/29/16 08:46 AM Re: Minkota 4 bank charger [Re: jfdawson]
forkduc Online   content
TFF Guru

Registered: 03/28/07
Posts: 11703
Loc: Plano,Texas
Thanks Jeff. I have the 460(no longer made) and Plano Marine is replacing it with a 440. Also, the other 3 banks did not show any lights and the reset buttons did nothing. Plugged it and unplugged many times nothing changed.
Thanks
Skip


Edited by forkduc (03/29/16 08:49 AM)

Top



© 1998-2018 OUTDOOR SITES NETWORK all rights reserved USA and Worldwide