Main Menu
Newest Members
H2O Express, Cjcarrier3, RCB, Camel1, sleepyt23
107393 Registered Users
Top Posters
TexDawg 88123
hopalong 78894
Pilothawk 76185
JDavis7873® 67390
John175® 66811
FattyMcButterpants 60846
Derek 🐝 59756
Tritonman 57921
LoneStarSon® 54255
SkeeterRonnie 53296
Forum Stats
107393 Members
60 Forums
854388 Topics
12188953 Posts

Max Online: 36273 @ 01/23/13 02:34 PM
Topic Options
#11457933 - 03/05/16 05:07 PM Trim problem
Roll Tide Ranger Offline

Registered: 01/08/07
Posts: 386
Loc: Krum, TX.
I have an '03 Ranger 518 DVX Comanche and occasionally my trim up will stop workin, Down still works fine, I reach under the console and wiggle the bundle of wires and it starts working again. Obviously, it is a short of some kind but my question is why would it be past the shifter? Does the wiring for some reason go forward of the shifter or am I just moving the bundle and maybe something is loose on the back of the shifter?

#11458088 - 03/05/16 06:57 PM Re: Trim problem [Re: Roll Tide Ranger]
gary purdy Offline
TFF Guru

Registered: 05/24/03
Posts: 11371
Loc: Littlefield Tx & Lake A. H. US...
Yes their is a wire connector there that splits the blue and green wires to go to the front T&T switch.
The world will not be destroyed by those who do evil, but by those who watch them without doing anything. Remember what He has done and remember that He is not done yet!-- GOD IS GOOD

#11458798 - 03/06/16 08:50 AM Re: Trim problem [Re: Roll Tide Ranger]
Roll Tide Ranger Offline

Registered: 01/08/07
Posts: 386
Loc: Krum, TX.
Ahhh Ok I apreciate the help


© 1998-2017 OUTDOOR SITES NETWORK all rights reserved USA and Worldwide