Main Menu
Advertisement
Affiliates
Advertisement
Newest Members
DennisSVC, Stickfish36, Ruler1, TomSawyer, poolsj
105731 Registered Users
Top Posters
TexDawg 85947
hopalong 78098
Pilothawk 75038
JDavis7873® 67382
John175 ® 64799
FattyMcButterpants 60790
Derek 🐝 58267
Tritonman 57558
LoneStarSon® 53252
SkeeterRonnie 52975
facebook
Forum Stats
105731 Members
60 Forums
851779 Topics
12134128 Posts

Max Online: 36273 @ 01/23/13 02:34 PM
Topic Options
#11416758 - 02/15/16 10:27 PM Power switch?
uttylerbass Offline
Outdoorsman

Registered: 03/23/09
Posts: 121
Loc: Texoma
I have lost all power to my lights, bilge and livewell. My engine runs but am I needing to replace the power switch? All fuses are good btw. Can someone help? I have a 1999 nitro w 150.

Thanks,
Michael

Top
#11416974 - 02/16/16 06:20 AM Re: Power switch? [Re: uttylerbass]
Dayne Offline
Extreme Angler

Registered: 12/16/06
Posts: 2968
You can buy all kinds of rocker switches at auto parts stores.

Top
#11417009 - 02/16/16 06:43 AM Re: Power switch? [Re: uttylerbass]
Flippin-Out Offline
Extreme Angler

Registered: 02/25/15
Posts: 1822
Loc: Magnolia, TX
Have you used a jumper to bypass the power switch as a test that it is the problem? A properly built boat should have a fuse or breaker in the battery compartment for the supply wire going to that power switch. Did you check for that also? If there is a breaker there, be aware that those can fail also. It is best to determine the true fault before buying parts.....

Top
#11419789 - 02/17/16 09:07 AM Re: Power switch? [Re: uttylerbass]
uttylerbass Offline
Outdoorsman

Registered: 03/23/09
Posts: 121
Loc: Texoma
I have not checked that yet. Thank you for the advice.

Top
#11423025 - 02/18/16 01:07 PM Re: Power switch? [Re: uttylerbass]
Mike Yeager Offline
Pro Angler

Registered: 07/31/14
Posts: 754
Loc: Cypress, TX
Unplug from your battery and let it sit for 15 minutes. If that doesn't work, get a volt meter and check your board (usually right behind the drivers seat and back behind the storage box)to make sure you are getting power to it. If you are, unhook the positive lead from the board. You will need to let it sit 10 minutes. It manually causes the board to reset. If that doesn't work turn your main power button on and slowly rock it back off. If you see your lights come on, you just have a bad switch. You pop it out and replace it. If it is a board, get ready to spend $700. I don't know if a 99 has a board though. Good luck!
_________________________
Mercury Pro Staff www.mercurymarine.com
Apache Corporation www.apachecorp.com
Power-Pole www.power-pole.com
Destroyer Bait Company www.destroyerbaitcompany.com
Ardent Reels www.ardentoutdoors.com

Top



© 1998-2017 OUTDOOR SITES NETWORK all rights reserved USA and Worldwide