Main Menu
Advertisement
Affiliates
Advertisement
Newest Members
Jbrown18, Travisly4, Russline, Rev.,Dr.Thaddious, Robere
107989 Registered Users
Top Posters
TexDawg 88591
hopalong 78895
Pilothawk 76386
John175® 67548
JDavis7873® 67390
FattyMcButterpants 60868
Derek 🐝 60239
Tritonman 57988
LoneStarSon® 54394
SkeeterRonnie 53365
facebook
Forum Stats
107989 Members
60 Forums
810845 Topics
10269598 Posts

Max Online: 36273 @ 01/23/13 02:34 PM
Topic Options
#11384307 - 02/01/16 03:13 PM Motor Trim Down Not Working
NatDog01 Offline
Outdoorsman

Registered: 06/12/12
Posts: 119
Loc: Spring, Texas
Hoping someone can help me out with a solution. I have a 2007 Yamaha 90hp 2-stroke. The motor "trim up" works fine, but the "trim down" went out on me while on the water. It still works at both the motor and bow switch, but does not work at the helm. I have researched and listened for a clicking sound, but I hear nothing when pressing the "trim down" at helm control. Is it possible I am having an issue where the wires connect to the relay, and if so, where is it located on the motor and what color wire should I be checking? Or is it likely I have something wrong at the helm control itself? Any advise would be appreciated.

Nat
_________________________
2008 Ranger 177TR

Top
#11384413 - 02/01/16 04:11 PM Re: Motor Trim Down Not Working [Re: NatDog01]
T Bird Offline
TFF Celebrity

Registered: 03/07/10
Posts: 6061
Loc: Temple, Texas "Rail Town USA"
Trim Sw. or connections bad on throttle.

Top
#11384460 - 02/01/16 04:41 PM Re: Motor Trim Down Not Working [Re: NatDog01]
NatDog01 Offline
Outdoorsman

Registered: 06/12/12
Posts: 119
Loc: Spring, Texas
yeah, I'm afraid it may be the switch or connection on the throttle. is there an easy way to disassemble it? seems pretty extensive to me.
_________________________
2008 Ranger 177TR

Top



© 1998-2018 OUTDOOR SITES NETWORK all rights reserved USA and Worldwide