Main Menu
Newest Members
Cowboys4life, bjk1, KeeperReaper, KEG, Fisherdad58
102390 Registered Users
Top Posters
TexDawg 82260
hopalong 73540
Pilothawk 72935
JDavis7873® 67375
FattyMcButterpants 60428
John175 ® 59617
Tritonman 56546
Derek 56155
SkeeterRonnie 52409
LoneStarSon® 52014
Forum Stats
102390 Members
60 Forums
854163 Topics
11203848 Posts

Max Online: 36273 @ 01/23/13 02:34 PM
Topic Options
#11218601 - 11/11/15 11:44 AM Lowrance Problems
Tanner Crim Offline

Registered: 01/24/14
Posts: 66
Ive been having problems with my HDS 10 units. I run a gen 1&2, last week i was on leon and it wouldn't pick up my gps location. I wasn't real worried about it and only had a few hours to fish. Went out monday and the same thing happened. Could it be my puck? Ive tried doing a soft reset and also turning them off, which has worked in the past. Also I turned my Gen 2 on when i launched the boat and it was working fine, went and parked the truck and came back to a black screen. I tried messing with it for a couple hours before giving up. The gen 2 is less than a year old. Any help is very much appreciated, I'm taking it in to the shop this afternoon to see what they say but some help could save the trip.

#11218616 - 11/11/15 11:46 AM Re: Lowrance Problems [Re: Tanner Crim]
coachallentca Offline
TFF Team Angler

Registered: 11/19/08
Posts: 3691
Loc: crowley
if you have a puck yes it could be. Can you try it on someone else's boat?

#11218637 - 11/11/15 11:53 AM Re: Lowrance Problems [Re: Tanner Crim]
Tanner Crim Offline

Registered: 01/24/14
Posts: 66
Im going to try that tonight coach, my biggest fear is that the gen 2 is burnt up. this will be the second one to burn up as i bought the gen 2 because the other gen 1 fried while fishing in the rain.

#11218901 - 11/11/15 02:10 PM Re: Lowrance Problems [Re: Tanner Crim]
WillieKetchum Offline
Pro Angler

Registered: 06/11/15
Posts: 547
Loc: Huntsville, TX
At least it'll be under warranty.

#11219113 - 11/11/15 04:09 PM Re: Lowrance Problems [Re: Tanner Crim]
David Burton Offline
Extreme Angler

Registered: 07/14/11
Posts: 1461
Loc: McKinney, TX
Was there any moisture in the air? My gen 2 got the boards wet, thought it was a goner. Once it all dried out, it was working again. I hope it is something small for you like a bad connection, or just a glitch requiring a power disconnect.
David Burton
2015 Skeeter FX 21

#11219123 - 11/11/15 04:14 PM Re: Lowrance Problems [Re: Tanner Crim]
BassBucknBeer Offline

Registered: 08/24/13
Posts: 375
Loc: Rockwall,TX
Go into the settings and make sure the correct antenna is selected. Mine did this once and it had the wrong one selected

Edited by BassBucknBeer (11/11/15 04:14 PM)

#11219907 - 11/11/15 11:51 PM Re: Lowrance Problems [Re: Tanner Crim]
RedShadWorm Offline

Registered: 05/25/11
Posts: 176
Loc: Dallas
I had these same symptoms once and it was a bad wire connection. Fixed that and it's been flawless since.


© 1998-2016 OUTDOOR SITES NETWORK all rights reserved USA and Worldwide