Main Menu
Advertisement
Affiliates
Advertisement
Newest Members
jfur, dburt2, AMG, ntxduffer, OKBlindHogg
108024 Registered Users
Top Posters
TexDawg 88644
hopalong 78895
Pilothawk 76394
John175® 67600
JDavis7873® 67390
FattyMcButterpants 60868
Derek 🐝 60292
Tritonman 57993
LoneStarSon® 54406
SkeeterRonnie 53367
facebook
Forum Stats
108024 Members
60 Forums
811385 Topics
10276383 Posts

Max Online: 36273 @ 01/23/13 02:34 PM
Topic Options
#11118187 - 09/21/15 04:12 PM Minn Kota Fortrex Problems
joemac224 Offline
Outdoorsman

Registered: 07/01/14
Posts: 179
Just bought a 24 volt Fortrex 80lb thrust for my boat. This weekend was fishing a tournament and kicked it up to 80-90% near the end of the day to move across a cove we were fishing and hit the other bank, when it went from running perfectly down to about 50% then just died in about 5 seconds. It was not a gradual change in loss of power, it jumped down in increments just like stated above. The batteries had a full charge on them at the start of the day, so batteries dying should not be a problem. What should I look at to start diagnosing the problem? Has this happened to anyone else? Thanks in advance.

Top
#11118229 - 09/21/15 04:34 PM Re: Minn Kota Fortrex Problems [Re: joemac224]
YAMADOGGY Offline
Outdoorsman

Registered: 11/26/03
Posts: 233
Loc: FT WORTH,TX,USA
WHATS YOUR VOLTAGE UP AT THE T/M CONNECTION? IS IT STILL DEAD AT TROLLING MOTOR SWITCH ETC?

Top
#11118503 - 09/21/15 06:33 PM Re: Minn Kota Fortrex Problems [Re: joemac224]
gary purdy Offline
TFF Guru

Registered: 05/24/03
Posts: 11424
Loc: Littlefield Tx & Lake A. H. US...
Sounds like you had a power connection burn up or water entered the motor through the prop seal.
_________________________
The world will not be destroyed by those who do evil, but by those who watch them without doing anything. Remember what He has done and remember that He is not done yet!-- GOD IS GOOD

Top
#11119878 - 09/22/15 11:59 AM Re: Minn Kota Fortrex Problems [Re: YAMADOGGY]
joemac224 Offline
Outdoorsman

Registered: 07/01/14
Posts: 179
Originally Posted By: YAMADOGGY
WHATS YOUR VOLTAGE UP AT THE T/M CONNECTION? IS IT STILL DEAD AT TROLLING MOTOR SWITCH ETC?


Finally got time today to test all of this. Had over 12.4-12.8 volts at each battery, and nothing at trolling motor. Read a lot about automatic breakers, so I figured that's what mine was, but it was a manual breaker so it didn't reset by itself. I reset it, and now have just over 25 volts at TM, and is working again. Should I be looking into replacing this breaker so it doesn't happen again in the future?

Top
#11119880 - 09/22/15 11:59 AM Re: Minn Kota Fortrex Problems [Re: gary purdy]
joemac224 Offline
Outdoorsman

Registered: 07/01/14
Posts: 179
Gary, see above, I would love your input on this as well! Thanks!

Top
#11120469 - 09/22/15 04:20 PM Re: Minn Kota Fortrex Problems [Re: joemac224]
YAMADOGGY Offline
Outdoorsman

Registered: 11/26/03
Posts: 233
Loc: FT WORTH,TX,USA
I just had my batt "1" breaker trip for the first time in 15 years when on manual high going from one tree line to another, I changed from 74 lb to 82 lb new motor, boat sat in barn, I was asking what might have caused trip.....I don't see rat knowing on the visible t/m wires from the aft batt comp. to the deck hook up. haven't been out since. interested in feed back the 82lb on my champ 186 moves along fast on wide open

Top



© 1998-2018 OUTDOOR SITES NETWORK all rights reserved USA and Worldwide