Main Menu
Advertisement
Affiliates
Advertisement
Newest Members
Linda Robert, Gnhattien, Robert black, Calexander, Nauti_Bouy
102725 Registered Users
Top Posters
TexDawg 82877
hopalong 74395
Pilothawk 73437
JDavis7873® 67377
FattyMcButterpants 60518
John175 ® 59900
Tritonman 56831
Derek 56424
SkeeterRonnie 52463
LoneStarSon® 52225
facebook
Forum Stats
102725 Members
61 Forums
859141 Topics
11270904 Posts

Max Online: 36273 @ 01/23/13 02:34 PM
Topic Options
#11103927 - 09/14/15 08:33 PM 2004 XR6 Oil Injection Problem
joemac224 Offline
Outdoorsman

Registered: 07/01/14
Posts: 143
Hey guys,

I have a 2004 150hp XR6 and have had a few problems with the oil injection from the remote tank to the one mounted on the engine. In the past (a year ago), I have been able to bleed out the air by loosening the lid to the on engine tank and letting it fill up from the remote tank, but this weekend the oil alarm went off and I tried to do this again, but after at least 5 minutes there was no change in the oil level. Remote tank is full of oil, lid is on tight, don't believe there are any cracks or loose connections in the hoses leading up to the tank mounted on the engine... Any suggestions? Thanks in advance!

Joseph

Top
#11104009 - 09/14/15 09:05 PM Re: 2004 XR6 Oil Injection Problem [Re: joemac224]
ssmith Online   content
Extreme Angler

Registered: 11/22/07
Posts: 2449
Loc: scotland tx
check the screen on the pickup tube in the tank inside the boat sometimes they will get clogged up.

Top
#11104364 - 09/15/15 05:26 AM Re: 2004 XR6 Oil Injection Problem [Re: joemac224]
TLW Offline
Extreme Angler

Registered: 11/16/06
Posts: 2004
Loc: ft worth
Originally Posted By: joemac224
Hey guys,

but this weekend the oil alarm went off and I tried to do this again, but after at least 5 minutes there was no change in the oil level. Remote tank is full of oil, lid is on tight, don't believe there are any cracks or loose connections in the hoses leading up to the tank mounted on the engine... Any suggestions? Thanks in advance!

Joseph


sounds like your sayin' tha motor tank is full but still getting an alarm??? tha "boat tank" will not give an alarm...

do you mean "remote tank" and "boat (main) tank" as one in tha same?




Edited by TLW (09/15/15 05:34 AM)

Top
#11104608 - 09/15/15 08:35 AM Re: 2004 XR6 Oil Injection Problem [Re: TLW]
joemac224 Offline
Outdoorsman

Registered: 07/01/14
Posts: 143
Exactly. The tank in the boat is full, and the one on the engine is not. I have bled it before, and the tank on the engine fills up, but when going through the same process to bleed it, now the tank on the engine is not filling up at all. Sorry for the confusion!

Top
#11104672 - 09/15/15 09:07 AM Re: 2004 XR6 Oil Injection Problem [Re: joemac224]
TLW Offline
Extreme Angler

Registered: 11/16/06
Posts: 2004
Loc: ft worth
Alrighty then... like ss says or pluse valve below starter.... are you gettin beep beep alarm?

Top
#11104699 - 09/15/15 09:14 AM Re: 2004 XR6 Oil Injection Problem [Re: joemac224]
RANGER SKI Online   content
Pro Angler

Registered: 12/18/09
Posts: 758
Loc: red oak texas
check the seal under the cap. it works on air pressure from the motor.

Top
#11106550 - 09/15/15 11:05 PM Re: 2004 XR6 Oil Injection Problem [Re: TLW]
joemac224 Offline
Outdoorsman

Registered: 07/01/14
Posts: 143
Yes, it is the beep beep beep alarm... I will check that out on either Thursday or Friday when I get out and let y'all know what I find.

Top
#11106552 - 09/15/15 11:06 PM Re: 2004 XR6 Oil Injection Problem [Re: joemac224]
joemac224 Offline
Outdoorsman

Registered: 07/01/14
Posts: 143
Thanks guys for all the help, I appreciate it. I will try these things and let y'all know what I find out.

Top
#11107048 - 09/16/15 09:18 AM Re: 2004 XR6 Oil Injection Problem [Re: joemac224]
gary purdy Online   content
TFF Guru

Registered: 05/24/03
Posts: 10535
Loc: Littlefield Tx & Lake A. H. US...
Like SS said screen clean and if it is clean, make sure nothings on top of the hoses or pinched at the cowling entry, check the boat mounted tank cap seals, then check and clean the pulse valve (have seen the guts come out of it) Should only have a very small hole. If you still are not getting oil to the motor mounted tank check the hoses again, then the valve in the fill hose and then the motor tank connection where the hose connects.
_________________________
“The world will not be destroyed by those who do evil, but by those who watch them without doing anything” GOD IS GOOD

Top



© 1998-2016 OUTDOOR SITES NETWORK all rights reserved USA and Worldwide