Main Menu
Advertisement
Affiliates
Advertisement
Newest Members
Robert Stidham, taramar7, Fishy306, Ruth, wellseasoned
107094 Registered Users
Top Posters
TexDawg 87865
hopalong 78878
Pilothawk 76053
JDavis7873® 67386
John175® 66431
FattyMcButterpants 60846
Derek 🐝 59567
Tritonman 57891
LoneStarSon® 54166
SkeeterRonnie 53241
facebook
Forum Stats
107094 Members
60 Forums
820767 Topics
10376279 Posts

Max Online: 36273 @ 01/23/13 02:34 PM
Topic Options
#11101008 - 09/13/15 07:07 PM Tilt/trim and motor
BC01 Offline
Outdoorsman

Registered: 12/05/09
Posts: 139
Loc: North texas
Today, went to go fishing and my tilt/trim and motor will not work. I have a Mercury 225 efi. My kill switch was in. At the motor, throttle, and the bow, when I try to tilt up and down I only hear a clicking noise at the motor. I have no sounds coming from the actual tilt and trim motor.

As far as my big engine not working, I have no clue.

I had to unscrew the tilt release and manually lift my motor. I was able to use my transom saver, but was worried about it breaking due to all the pressure.

Any help will be great. Thanks

Top
#11101030 - 09/13/15 07:18 PM Re: Tilt/trim and motor [Re: BC01]
2014NITROZ-7 Online   content
Angler

Registered: 05/06/10
Posts: 430
Loc: Texas
Sounds like one or both solenoids are bad.

Top
#11102225 - 09/13/15 11:14 PM Re: Tilt/trim and motor [Re: BC01]
Bobby Milam Online   content
TFF Team Angler

Registered: 07/13/14
Posts: 3174
Loc: Arlington
Make sure there isn't some type of reset. I hit a stump and mine was stuck all the way down. I finally found a reset and everything went back to normal. Haven't had a problem since

Top
#11102583 - 09/14/15 09:00 AM Re: Tilt/trim and motor [Re: BC01]
gary purdy Online   content
TFF Guru

Registered: 05/24/03
Posts: 11351
Loc: Littlefield Tx & Lake A. H. US...
Very unusual for a Merc to stop working both up and down at the same time. Check the wires going to the trim motor for voltage when switch activated. If it gets voltage the trim motor is bad, if not check supply voltage to the relays. then the relays. Never seen a re-set on a Merc trim system.
_________________________
The world will not be destroyed by those who do evil, but by those who watch them without doing anything. Remember what He has done and remember that He is not done yet!-- GOD IS GOOD

Top
#11102770 - 09/14/15 10:52 AM Re: Tilt/trim and motor [Re: BC01]
BC01 Offline
Outdoorsman

Registered: 12/05/09
Posts: 139
Loc: North texas
Noticed corrosion around my positive battery connection. Sprayed and cleaned and now it works. Strange how something that small made a difference

Top



© 1998-2017 OUTDOOR SITES NETWORK all rights reserved USA and Worldwide