Main Menu
Newest Members
Bowhunter2323, BankAngler81, CLove01, Chris Phillips, dac11011
107386 Registered Users
Top Posters
TexDawg 88111
hopalong 78894
Pilothawk 76180
JDavis7873® 67390
John175® 66800
FattyMcButterpants 60846
Derek 🐝 59754
Tritonman 57915
LoneStarSon® 54253
SkeeterRonnie 53295
Forum Stats
107386 Members
60 Forums
873839 Topics
12418153 Posts

Max Online: 36273 @ 01/23/13 02:34 PM
Topic Options
#11066339 - 08/26/15 09:42 PM Power pole help!
ShaneM Offline

Registered: 12/04/14
Posts: 49
Just installed pro series 2. When I powered it up it worked fine. I stepped away for a bit and when I went back it was beeping and a red light was flashing. I disconnected the unit and then reconnected it. The green light comes on and stays on. The program button doesn't respond. The other pole is working fine. Responds to remotes perfect. Not sure why green light stays on. Tried the function on the remote that switches from one pole to both. Nothing. The up down arrows don't work in the pump either.

Any ideas??

#11066372 - 08/26/15 10:02 PM Re: Power pole help! [Re: ShaneM]
CB2011 Offline

Registered: 06/29/12
Posts: 143
Call power pole. Their customer service is outstanding!

#11066642 - 08/27/15 07:18 AM Re: Power pole help! [Re: CB2011]
Comanche487 Offline

Registered: 07/31/14
Posts: 132
Loc: scurry, tx
Originally Posted By: CB2011
Call power pole. Their customer service is outstanding!

"Fish On"

#11067146 - 08/27/15 11:24 AM Re: Power pole help! [Re: ShaneM]
Classic Fiberglass Offline
Pro Angler

Registered: 05/19/10
Posts: 885
Loc: Denton, Texas
Check the ground


© 1998-2017 OUTDOOR SITES NETWORK all rights reserved USA and Worldwide