Main Menu
Advertisement
Affiliates
Advertisement
Newest Members
Midland RV & Boat Storage, GoHappy Fishing, Griffs, Rob Campbell, Thomas101
102715 Registered Users
Top Posters
TexDawg 82862
hopalong 74389
Pilothawk 73427
JDavis7873® 67377
FattyMcButterpants 60518
John175 ® 59877
Tritonman 56823
Derek 56401
SkeeterRonnie 52453
LoneStarSon® 52221
facebook
Forum Stats
102715 Members
61 Forums
858978 Topics
11268460 Posts

Max Online: 36273 @ 01/23/13 02:34 PM
Topic Options
#11043940 - 08/15/15 04:02 PM Minn Kota Terrova Help
Duke 59 Offline
Outdoorsman

Registered: 01/02/12
Posts: 171
I was out on the lake thursday and while running the tolling motor it would shut down.....if I used the remote to start it back up....it would run for a couple seconds then shut down. I thought it might be that the batteries needed charged.

I had it on the two bank charger since thursday afternoon and when I looked at it this morning...the charger showed green for both batteries. When I deployed the shaft into the water, I could not get it to start from either the remote or the foot controller....also none of the display lights on the trolling motor base are lit.

What do you think?

Thanks, greg

Top
#11043987 - 08/15/15 04:44 PM Re: Minn Kota Terrova Help [Re: Duke 59]
44 Diesel Online   content
TFF Team Angler

Registered: 12/25/12
Posts: 3422
Loc: Burleson,TX
Check the breaker if there is one (should have installed a 50 -60 amp breaker), check all connections at battery and the trolling motor plug

Top
#11045381 - 08/16/15 01:05 PM Re: Minn Kota Terrova Help [Re: Duke 59]
Jones Trolling Motor Online   content
Angler

Registered: 05/01/11
Posts: 431
Loc: NE Texas/SW Arkansas
If it's not lighting the lights, the first thing to do is to make sure proper voltage is getting to the trolling motor. A voltmeter is your friend for this.
_________________________

www.jonestrollingmotor.com
texarkana, Ark/Tx

Top
#11046010 - 08/16/15 07:49 PM Re: Minn Kota Terrova Help [Re: Duke 59]
Duke 59 Offline
Outdoorsman

Registered: 01/02/12
Posts: 171
I should have added that when I try to use the remote....I hit the remote buttons....the remote screen lights up, but after about 2 or 3 seconds it just shuts down as if it is not making a connection.

Top
#11046364 - 08/16/15 11:41 PM Re: Minn Kota Terrova Help [Re: Duke 59]
44 Diesel Online   content
TFF Team Angler

Registered: 12/25/12
Posts: 3422
Loc: Burleson,TX
If your remote turns off then it may be a remote battery issue, your remote should stay on even if it not getting a connection. If your green power light on the terrova light is not lighting up then you have a bad connection somewhere or a breaker is tripped and not getting power.

Top
#11046366 - 08/16/15 11:46 PM Re: Minn Kota Terrova Help [Re: Duke 59]
Bobby Milam Online   content
Extreme Angler

Registered: 07/13/14
Posts: 1995
Loc: Arlington
I had a problem with my remote connection a few weeks ago. Took the back off and twisted the battery and it fixed it

Top
#11048376 - 08/17/15 11:16 PM Re: Minn Kota Terrova Help [Re: Duke 59]
Duke 59 Offline
Outdoorsman

Registered: 01/02/12
Posts: 171
Found my problem today.....circuit breaker on line coming out of battery had tripped.....reset and everything worked today.

Not sure why it tripped in the first place and will need to keep an eye on it.

Also, FYI....when the breaker was tripped and no power was getting to the trolling motor....the remote control would not stay on.....it appears if it doesn't make a connection to a powered unit, it shuts down....FYI

Top



© 1998-2016 OUTDOOR SITES NETWORK all rights reserved USA and Worldwide