Main Menu
Advertisement
Affiliates
Advertisement
Newest Members
laserbeak, ClayMaster100, JonnyW, Chrisb123, Craig Blaesing
108017 Registered Users
Top Posters
TexDawg 88626
hopalong 78895
Pilothawk 76393
John175® 67568
JDavis7873® 67390
FattyMcButterpants 60868
Derek 🐝 60270
Tritonman 57993
LoneStarSon® 54400
SkeeterRonnie 53366
facebook
Forum Stats
108017 Members
60 Forums
811176 Topics
10273776 Posts

Max Online: 36273 @ 01/23/13 02:34 PM
Topic Options
#11009661 - 07/30/15 10:40 AM Mercury help
Aggie34 Offline
Outdoorsman

Registered: 02/01/15
Posts: 207
Loc: Glen Rose
I have a 2001 mercury 225 efi. For some reason when I idle and try to take off it bogs down, but if I put it in neutral and Rev it up then out it back in gear it will take off just fine. But for some reason it is flooding itself at an idle. Everything looks good. The only thing I've found it the fuel pump is a little higher than it should be. Any ideas?


Edited by Aggie34 (07/30/15 10:41 AM)
_________________________

Top
#11012564 - 07/31/15 05:22 PM Re: Mercury help [Re: Aggie34]
Mike2718 Offline
Outdoorsman

Registered: 05/05/10
Posts: 123
Loc: Seabrook, TX
Try posting on on the bbcboards forum. Here is the link. http://www.bbcboards.net/ Scroll down to the mercury forum & post your question there. Don can usually figure out just about anything on a mercury motor. He has been a mercury mechanic forever. BE SURE to include your serial # in your post or it will not get answered.
_________________________
Have a Blessed Day,
Mike

Top
#11013786 - 08/01/15 01:16 PM Re: Mercury help [Re: Aggie34]
Aggie34 Offline
Outdoorsman

Registered: 02/01/15
Posts: 207
Loc: Glen Rose
Thanks, never used that site. Just posted it so we shall see what they think

Top



© 1998-2018 OUTDOOR SITES NETWORK all rights reserved USA and Worldwide