Main Menu
Newest Members
Mr Archie, Warlock55, BankBiteHannah, charge7, dmol52
102356 Registered Users
Top Posters
TexDawg 82212
hopalong 73459
Pilothawk 72878
JDavis7873® 67375
FattyMcButterpants 60428
John175 ® 59617
Tritonman 56546
Derek 56125
SkeeterRonnie 52401
LoneStarSon® 51988
Forum Stats
102356 Members
60 Forums
853729 Topics
11196689 Posts

Max Online: 36273 @ 01/23/13 02:34 PM
Topic Options
#10986117 - 07/18/15 10:23 PM Motor missing slightly at full throttle
mikey6345 Offline

Registered: 09/29/14
Posts: 203
Loc: Dallas
Ok folks.

Have a 2009 50 hp 2 stroke Mercury. I am having an issue where sometimes at full throttle or trimming the motor at speed that the motor surging or missing slightly like it is either not getting gas or a filter is blocked. Put a new fuel line on recently as it was degrading a bit.

Any troubleshooting thoughts for me here. Filter or fuel pump?


#10986710 - 07/19/15 11:14 AM Re: Motor missing slightly at full throttle [Re: mikey6345]
Capt Craig Offline
Extreme Angler

Registered: 08/25/09
Posts: 1045
Loc: Richland-Chambers
My friend's motor was doing that. We went through the fuel system and couldn't figure it out. Finally we were able to determine that the motor was over revving and the engines protection system was shutting it down. We changed the prop and never had any further issues.
Capt. Craig Copeland

2013 Nautic Star 2110 Shallow Bay Boat

Nautic Star Boats Pro Staff (
Redneck Fish'n Jigs Pro Staff (


© 1998-2016 OUTDOOR SITES NETWORK all rights reserved USA and Worldwide