Main Menu
Advertisement
Affiliates
Advertisement
Newest Members
TillerBC, I do what I want, Wetmyhook, FrontierMan, RiverMann
103529 Registered Users
Top Posters
TexDawg 84003
hopalong 75456
Pilothawk 74021
JDavis7873® 67380
John175 ® 61809
FattyMcButterpants 60637
Tritonman 57277
Derek 57012
SkeeterRonnie 52606
LoneStarSon® 52531
facebook
Forum Stats
103529 Members
61 Forums
868958 Topics
11402372 Posts

Max Online: 36273 @ 01/23/13 02:34 PM
Topic Options
#10986117 - 07/18/15 10:23 PM Motor missing slightly at full throttle
mikey6345 Offline
Outdoorsman

Registered: 09/29/14
Posts: 220
Loc: Dallas
Ok folks.

Have a 2009 50 hp 2 stroke Mercury. I am having an issue where sometimes at full throttle or trimming the motor at speed that the motor surging or missing slightly like it is either not getting gas or a filter is blocked. Put a new fuel line on recently as it was degrading a bit.

Any troubleshooting thoughts for me here. Filter or fuel pump?

Thx

Top
#10986710 - 07/19/15 11:14 AM Re: Motor missing slightly at full throttle [Re: mikey6345]
Capt Craig Online   content
Extreme Angler

Registered: 08/25/09
Posts: 1086
Loc: Richland-Chambers
My friend's motor was doing that. We went through the fuel system and couldn't figure it out. Finally we were able to determine that the motor was over revving and the engines protection system was shutting it down. We changed the prop and never had any further issues.
_________________________
Capt. Craig Copeland

2013 Nautic Star 2110 Shallow Bay Boat

Humminbird HELIX 12 CHIRP MEGA SI GPS G2N
Nautic Star Boats Pro Staff (nauticstarboats.com)
Redneck Fish'n Jigs Pro Staff (redneckfishn.com)

Top



© 1998-2016 OUTDOOR SITES NETWORK all rights reserved USA and Worldwide