Main Menu
Advertisement
Affiliates
Advertisement
Newest Members
BigBoater2017, mavgeorge82, Cheryl How, DOFC, specsultan
106392 Registered Users
Top Posters
TexDawg 86962
hopalong 78792
Pilothawk 75590
JDavis7873® 67385
John175 ® 65747
FattyMcButterpants 60793
Derek 🐝 58915
Tritonman 57724
LoneStarSon® 53725
SkeeterRonnie 53105
facebook
Forum Stats
106392 Members
61 Forums
862263 Topics
12255182 Posts

Max Online: 36273 @ 01/23/13 02:34 PM
Topic Options
#10972536 - 07/12/15 07:15 PM Lowrance
General Jigs Offline
Extreme Angler

Registered: 02/26/09
Posts: 1226
Loc: tx
I just wired up my brand new lowrance elite 4 chirp, GPS and it will not power on. I have not connected the cable for the transducer. I am getting power all the way to the Unit head, but no power up.

Do I have to connect the transducer cable for the unit to power on?


Edited by General Jigs (07/15/15 08:55 AM)
_________________________
“For there is one God and one mediator between God and men, the man Christ Jesus, who gave himself as a ransom for all men—the testimony given in its proper time.”- 1 Timothy 2:5-6

Top
#10972759 - 07/12/15 08:44 PM Re: Help please! Lowrance [Re: General Jigs]
Jtrussell Offline
Outdoorsman

Registered: 02/15/14
Posts: 112
Loc: Tawakoni
Make sure the connector is in the correct position and screwed down. Don't know if the ducer cable has to be hooked up for it to come on or not. I have the elite 4x dsi. And another obvious " is the battery charged"?

Top
#10973121 - 07/13/15 05:57 AM Re: Help please! Lowrance [Re: General Jigs]
YAKaddict Offline
Pro Angler

Registered: 11/02/14
Posts: 533
Loc: Plano
Should be plug and play. As jt said your battery may not have power. What kind of battery are you using. Hopefully at least a 12v deer feeder battery

Top
#10973468 - 07/13/15 09:27 AM Re: Help please! Lowrance [Re: General Jigs]
MilesHunter Offline
Pro Angler

Registered: 03/17/13
Posts: 819
Loc: Mansfield, TX
Is the fuse installed? Battery charged? Cable locked in place on the unit? Double check connections. The xducer cable does not need to be connected for the unit to power up. If you checked all that then contact Lowrance. Good luck.
_________________________
Miles

Top
#10973469 - 07/13/15 09:27 AM Re: Help please! Lowrance [Re: General Jigs]
Rhino68W Offline
TFF Celebrity

Registered: 11/06/14
Posts: 6619
Loc: Benbrook, TX
Also, make sure you are pushing the power cord ALL the way in. I thought mine was broken yesterday morning, just to realize I wasn't plugging it in all of the way.
_________________________
Facebook | Kayak Fishing Military Veterans

Top
#10974082 - 07/13/15 01:24 PM Re: Help please! Lowrance [Re: General Jigs]
General Jigs Offline
Extreme Angler

Registered: 02/26/09
Posts: 1226
Loc: tx
I got it working fellas, thanks for the replies. now to figure out how I want the settings before I head out on the water.

_________________________
“For there is one God and one mediator between God and men, the man Christ Jesus, who gave himself as a ransom for all men—the testimony given in its proper time.”- 1 Timothy 2:5-6

Top



© 1998-2017 OUTDOOR SITES NETWORK all rights reserved USA and Worldwide