Main Menu
Advertisement
Affiliates
Advertisement
Newest Members
Lilleyj7, D.RODGERS, mikyfran, SaltwaterGospel, Nicholas Moudy
102741 Registered Users
Top Posters
TexDawg 82901
hopalong 74411
Pilothawk 73456
JDavis7873® 67377
FattyMcButterpants 60518
John175 ® 59942
Tritonman 56844
Derek 56448
SkeeterRonnie 52467
LoneStarSon® 52229
facebook
Forum Stats
102741 Members
61 Forums
859433 Topics
11275231 Posts

Max Online: 36273 @ 01/23/13 02:34 PM
Topic Options
#10972536 - 07/12/15 07:15 PM Lowrance
General Jigs Offline
Extreme Angler

Registered: 02/26/09
Posts: 1143
Loc: Benbrook
I just wired up my brand new lowrance elite 4 chirp, GPS and it will not power on. I have not connected the cable for the transducer. I am getting power all the way to the Unit head, but no power up.

Do I have to connect the transducer cable for the unit to power on?


Edited by General Jigs (07/15/15 08:55 AM)
_________________________
“For there is one God and one mediator between God and men, the man Christ Jesus, who gave himself as a ransom for all men—the testimony given in its proper time.”- 1 Timothy 2:5-6

Top
#10972759 - 07/12/15 08:44 PM Re: Help please! Lowrance [Re: General Jigs]
Jtrussell Offline
Outdoorsman

Registered: 02/15/14
Posts: 112
Loc: Tawakoni
Make sure the connector is in the correct position and screwed down. Don't know if the ducer cable has to be hooked up for it to come on or not. I have the elite 4x dsi. And another obvious " is the battery charged"?

Top
#10973121 - 07/13/15 05:57 AM Re: Help please! Lowrance [Re: General Jigs]
YAKaddict Offline
Angler

Registered: 11/02/14
Posts: 465
Loc: Plano
Should be plug and play. As jt said your battery may not have power. What kind of battery are you using. Hopefully at least a 12v deer feeder battery

Top
#10973468 - 07/13/15 09:27 AM Re: Help please! Lowrance [Re: General Jigs]
MilesHunter Online   content
Pro Angler

Registered: 03/17/13
Posts: 549
Loc: Mansfield, TX
Is the fuse installed? Battery charged? Cable locked in place on the unit? Double check connections. The xducer cable does not need to be connected for the unit to power up. If you checked all that then contact Lowrance. Good luck.
_________________________
Miles

Top
#10973469 - 07/13/15 09:27 AM Re: Help please! Lowrance [Re: General Jigs]
Rhino68W Online   content
TFF Celebrity

Registered: 11/06/14
Posts: 5675
Loc: Benbrook, TX
Also, make sure you are pushing the power cord ALL the way in. I thought mine was broken yesterday morning, just to realize I wasn't plugging it in all of the way.
_________________________
Goats are like mushrooms. If you shoot a duck, i'm a toaster.

Top
#10974082 - 07/13/15 01:24 PM Re: Help please! Lowrance [Re: General Jigs]
General Jigs Offline
Extreme Angler

Registered: 02/26/09
Posts: 1143
Loc: Benbrook
I got it working fellas, thanks for the replies. now to figure out how I want the settings before I head out on the water.

_________________________
“For there is one God and one mediator between God and men, the man Christ Jesus, who gave himself as a ransom for all men—the testimony given in its proper time.”- 1 Timothy 2:5-6

Top



© 1998-2016 OUTDOOR SITES NETWORK all rights reserved USA and Worldwide