Main Menu
Advertisement
Affiliates
Advertisement
Newest Members
liprippen, C. Walker, ronws67, Leftridge, Panhandleag18
102710 Registered Users
Top Posters
TexDawg 82858
hopalong 74380
Pilothawk 73417
JDavis7873® 67377
FattyMcButterpants 60518
John175 ® 59868
Tritonman 56822
Derek 56400
SkeeterRonnie 52453
LoneStarSon® 52212
facebook
Forum Stats
102710 Members
61 Forums
858858 Topics
11266872 Posts

Max Online: 36273 @ 01/23/13 02:34 PM
Topic Options
#10821210 - 05/05/15 07:29 PM My new Talons
rowlettfisherman Offline
Pro Angler

Registered: 01/25/12
Posts: 719
So I decided to treat myself to a pair of 12' talons last month. Had a tournament this last weekend and one of them decided to quit working. Only the third time ive had them out. Still has power to the fuse, but nothing on it works. Anyone else had one break? What did you do, contact Minnkota or someone local?

Top
#10821343 - 05/05/15 08:14 PM Re: My new Talons [Re: rowlettfisherman]
KnotEnuff Offline
Angler

Registered: 08/09/03
Posts: 403
Loc: Burleson,tx,usa
Mine malfunctioned right away. Went to Boris Marine Electronics had me going again promptly.
_________________________

Top
#10821643 - 05/05/15 09:45 PM Re: My new Talons [Re: rowlettfisherman]
C.J Offline
Pro Angler

Registered: 08/29/11
Posts: 618
Loc: Belton Texas
I've had mine for two years with zero issues
_________________________
www.powertackle.com

Top
#10821957 - 05/06/15 06:39 AM Re: My new Talons [Re: rowlettfisherman]
Lewis Ville Online   content
Angler

Registered: 07/28/07
Posts: 324
I'd contact the manufacturer as new as they are. They might just replace it. Great customer service.

Top
#10822060 - 05/06/15 07:48 AM Re: My new Talons [Re: Lewis Ville]
Happykamper Online   content
TFF Celebrity

Registered: 01/20/07
Posts: 7377
Loc: Southlake, Texas
I hate it when you buy something new and it does not work right out of the box, no doubt they will take care of it, still a pain in the butt, a board went out in one of my P poles right after I got my boat, I guess it is part of being a boat owner.

Top
#10822202 - 05/06/15 08:51 AM Re: My new Talons [Re: rowlettfisherman]
Lil' Louie Offline
TFF Celebrity

Registered: 02/25/07
Posts: 9387
Loc: Lewisville/Lake Fork
well that sucks. Had mine since October. No issues. I'm sure they will replace it no problem. Still a PITA though...
_________________________


www.traininglikechampions.com

PB 12.88lbs, Lake Fork 3-17-2013 8:45 a.m.



Top
#10822226 - 05/06/15 08:58 AM Re: My new Talons [Re: rowlettfisherman]
Lee in Texas Offline
TFF Celebrity

Registered: 03/23/13
Posts: 8946
Loc: Wise County Texas
Had my one about 6 months, so far no problems. Like yours, 12'.....
Sorry to hear about your problem. They should work flawlessly..
I'm guessing you have already checked for dirt/sand drawn up into the housing? Just a thought....
Contact them, I'm told the C/S is great...Minn Kota that is...
God Bless


Edited by Lee in Texas (05/06/15 09:05 AM)
_________________________
http://www.finfeatherresort.com/index.asp - Best Folks on Toledo Bend !!!
http://www.markpacklakefork.com/ - Great Source!!
http://bassclubofthewest.angelfire.com/ -West Ft Worth Bass Club
http://www.gleasonfishing.com/ Darold Gleason
2004 Stratos Complete Restoration 2014!!! With Much Gratitude to:
Cal's Marine/Azle,Texas (817)300-2827

Top
#10822346 - 05/06/15 09:35 AM Re: My new Talons [Re: rowlettfisherman]
C_Fisher Online   content
Pro Angler

Registered: 07/05/07
Posts: 569
Loc: weatherford, tx
Mine have been raised and lowered probably 2500 times with no problems. Im sure they will fix or replace it.

Top
#10822380 - 05/06/15 09:46 AM Re: My new Talons [Re: rowlettfisherman]
Baylor_Guy™ Offline
TFF Guru

Registered: 05/07/04
Posts: 20459
Loc: Kemp, Texas
Get them to me as soon as possible because the 10 and 12' go back to the factory for R&D since this is the first year out and they will send you a new one. But I have to have the old one to send back first. I can get you taken care of.
_________________________

Top
#10822510 - 05/06/15 10:24 AM Re: My new Talons [Re: rowlettfisherman]
Big 10 Inch Online   sick
Angler

Registered: 01/18/11
Posts: 316
Originally Posted By: rowlettfisherman
So I decided to treat myself to a pair of 12' talons last month. Had a tournament this last weekend and one of them decided to quit working. Only the third time ive had them out. Still has power to the fuse, but nothing on it works. Anyone else had one break? What did you do, contact Minnkota or someone local?


Give me a little more information. Are you wired directly to your battery or do you have the quick disconnect plug? If you have the quick disconnect plug pull it apart and check all the connections on both sides of the plug. Make sure you have it tight and sealed good so water can not enter.

Top
#10822539 - 05/06/15 10:31 AM Re: My new Talons [Re: rowlettfisherman]
NitroDigger Offline
Outdoorsman

Registered: 03/12/15
Posts: 88
Loc: Denton Co, Tx.
I love my 10'ers. Work great
_________________________
If this Hat is missing, I'm Gone FISHING

Top
#10824567 - 05/06/15 10:51 PM Re: My new Talons [Re: rowlettfisherman]
rowlettfisherman Offline
Pro Angler

Registered: 01/25/12
Posts: 719
They are direct to the battery worked all day no issues. When I parked at the ramp one wouldn't work go down. When I got home I checked the fuses. They were fine. Unit has power but no lights even come on

Top



© 1998-2016 OUTDOOR SITES NETWORK all rights reserved USA and Worldwide