Main Menu
Advertisement
Affiliates
Advertisement
Newest Members
DerVon, HookedAZ, Kelly Hill, Drewski81, Tucker01
103171 Registered Users
Top Posters
TexDawg 83701
hopalong 74996
Pilothawk 73824
JDavis7873® 67378
John175 ® 61109
FattyMcButterpants 60594
Tritonman 57174
Derek 56843
SkeeterRonnie 52571
LoneStarSon® 52421
facebook
Forum Stats
103171 Members
62 Forums
865606 Topics
11362981 Posts

Max Online: 36273 @ 01/23/13 02:34 PM
Topic Options
#10807738 - 04/29/15 08:28 PM brand new Humminbird 688 and the GPS does not work?
Skeeter man ZX225 Offline
Extreme Angler

Registered: 05/30/03
Posts: 2509
Just got through hooking up this unit and the GPS does not work, just get a white screen?? Any suggestions? Thanks in advance

Top
#10816490 - 05/04/15 04:15 AM Re: brand new Humminbird 688 and the GPS does not work? [Re: Skeeter man ZX225]
Ltcm09 Offline
Outdoorsman

Registered: 05/27/14
Posts: 193
Might want to contact Humminbird on that one.

Pics would help tho

Top
#10839582 - 05/12/15 08:32 PM Re: brand new Humminbird 688 and the GPS does not work? [Re: Skeeter man ZX225]
john200 Offline
Outdoorsman

Registered: 04/13/07
Posts: 92
I had a similar problem on my 688 it would show no satellites locked on. I wired it up with same wire my old lowrance used. Turned out that was the problem. That wire wasn't 18 guage . It was only reading 11.8 volts and my back unit was registering 13.6 volts. Ran new wire to front and gps locked on right away. Good luck.

Top



© 1998-2016 OUTDOOR SITES NETWORK all rights reserved USA and Worldwide