Main Menu
Advertisement
Affiliates
Advertisement
Newest Members
RPerry300WM, pop r, jellyworker, slugtooth, Sineypem
105929 Registered Users
Top Posters
TexDawg 86367
hopalong 78625
Pilothawk 75181
JDavis7873® 67382
John175 ® 65087
FattyMcButterpants 60793
Derek 🐝 58510
Tritonman 57653
LoneStarSon® 53416
SkeeterRonnie 53015
facebook
Forum Stats
105929 Members
60 Forums
805012 Topics
10174406 Posts

Max Online: 36273 @ 01/23/13 02:34 PM
Topic Options
#10771694 - 04/16/15 07:51 AM lost speed
Rayburnrun Offline
Angler

Registered: 10/29/10
Posts: 337
Loc: Etoile, Tx.
I recently had to change my lower unit on a 225 merc pro xs. Brand new lower unit and had prop refurbished. Before I could run up to 69 mph, now 64 is top speed. Does a new lower unit need broke in or did they screw my prop up.

Top
#10771735 - 04/16/15 08:12 AM Re: lost speed [Re: Rayburnrun]
Tommy Yetts Offline
TFF Team Angler

Registered: 12/14/02
Posts: 3475
Loc: Rockwall, TX USA
I would suspect the prop wasn't done properly. Did you gain RPMs or lose RPMs?
_________________________
Rockwall Marine
Tommy Yetts

www.rockwallmarine.com

Top
#10771772 - 04/16/15 08:28 AM Re: lost speed [Re: Rayburnrun]
TLW Online   content
Extreme Angler

Registered: 11/16/06
Posts: 2206
Loc: ft worth
what gear case was on it (should have been a TM or Sporty) and what gear case replaced it? if it was replaced with a standard 3.0 gear case then ratio may be different... any change in wfo rpm's?

Top
#10772368 - 04/16/15 12:01 PM Re: lost speed [Re: Rayburnrun]
steve@hydrodynamics Offline
TFF Celebrity

Registered: 08/25/06
Posts: 6749
Loc: Quitman,Tx
i would suspect the prop
_________________________
www.hydrodynamics-usa.com
903-763-5225





Top



© 1998-2017 OUTDOOR SITES NETWORK all rights reserved USA and Worldwide