Main Menu
Newest Members
H2O Express, Cjcarrier3, RCB, Camel1, sleepyt23
107393 Registered Users
Top Posters
TexDawg 88125
hopalong 78894
Pilothawk 76186
JDavis7873® 67390
John175® 66811
FattyMcButterpants 60846
Derek 🐝 59758
Tritonman 57922
LoneStarSon® 54255
SkeeterRonnie 53300
Forum Stats
107393 Members
60 Forums
854398 Topics
12189123 Posts

Max Online: 36273 @ 01/23/13 02:34 PM
Topic Options
#10771694 - 04/16/15 07:51 AM lost speed
Rayburnrun Offline

Registered: 10/29/10
Posts: 341
Loc: Etoile, Tx.
I recently had to change my lower unit on a 225 merc pro xs. Brand new lower unit and had prop refurbished. Before I could run up to 69 mph, now 64 is top speed. Does a new lower unit need broke in or did they screw my prop up.

#10771735 - 04/16/15 08:12 AM Re: lost speed [Re: Rayburnrun]
Tommy Yetts Offline
TFF Team Angler

Registered: 12/14/02
Posts: 3572
Loc: Rockwall, TX USA
I would suspect the prop wasn't done properly. Did you gain RPMs or lose RPMs?
Rockwall Marine
Tommy Yetts

#10771772 - 04/16/15 08:28 AM Re: lost speed [Re: Rayburnrun]
TLW Online   content
Extreme Angler

Registered: 11/16/06
Posts: 2275
Loc: ft worth
what gear case was on it (should have been a TM or Sporty) and what gear case replaced it? if it was replaced with a standard 3.0 gear case then ratio may be different... any change in wfo rpm's?

#10772368 - 04/16/15 12:01 PM Re: lost speed [Re: Rayburnrun]
steve@hydrodynamics Offline
TFF Celebrity

Registered: 08/25/06
Posts: 6811
Loc: Quitman,Tx
i would suspect the prop


© 1998-2017 OUTDOOR SITES NETWORK all rights reserved USA and Worldwide