Main Menu
Advertisement
Affiliates
Advertisement
Newest Members
creaturefeature, charlesc, Lrs21, mbparker, Dan O
104814 Registered Users
Top Posters
TexDawg 84898
hopalong 77269
Pilothawk 74626
JDavis7873® 67382
John175 ® 63147
FattyMcButterpants 60665
Derek 🐝 57563
Tritonman 57448
SkeeterRonnie 52884
LoneStarSon® 52794
facebook
Forum Stats
104814 Members
60 Forums
841252 Topics
12002455 Posts

Max Online: 36273 @ 01/23/13 02:34 PM
Topic Options
#10762937 - 04/12/15 10:59 PM Garmin 93sv turning off while running.
JoeyC Offline
Angler

Registered: 03/22/12
Posts: 322
Loc: Grand Prairie
I just installed a Garmin 93sv. The unit seems to lose power when I'm running. It is fine at idle or slow speeds but once I hit 30+ mph it cuts off. This was extremely annoying as I was at broken bow for the first time and I kept having to stop to turn the unit back on so I could figure out where I was. What should I be checking?

I thought maybe the connections were not good but I'm always able to turn the unit back on and the issue only happens while running


Edited by JoeyC (04/12/15 11:03 PM)

Top
#10767303 - 04/14/15 11:44 AM Re: Garmin 93sv turning off while running. [Re: JoeyC]
Todd Driscoll Offline
Outdoorsman

Registered: 11/22/08
Posts: 127
I suggest it is a faulty wire splice, fuse link, connection, etc. In cases like yours, vibrations caused by running or by wave action can exacerbate wiring issues.

Top
#10885003 - 05/31/15 07:54 AM Re: Garmin 93sv turning off while running. [Re: JoeyC]
Oshkosh Offline
Green Horn

Registered: 05/30/15
Posts: 1
I installed my Garmin 93sv last weekend. It tried to power up but shut down when traveling at high speed. Worked fine at slow speeds. Garmin Support said it was probably a loose connection that vibrated at higher speed. They suggested to connect directly to the battery not the fuse panel. Mine went to the fuse panel. I'm going to solder wire connections instead of using crimped connections.

I also tried to load the new 2.60 version software. Currently 2.5 in the unit. Download from Garmin site to my computer went fine. The download on my computer was loaded to the SD card no problem. When I followed direction to load the SD card after "Agree" selected the 93sv never gave me OK to load software. I reformatted the SD card will try again next week. Any ideas.

Top
#10885060 - 05/31/15 08:51 AM Re: Garmin 93sv turning off while running. [Re: JoeyC]
JoeyC Offline
Angler

Registered: 03/22/12
Posts: 322
Loc: Grand Prairie
I ended up redoing the splices and making sure the connectors were extra tight. I haven't had an issue since. My units both go to fuse box as well.

Top



© 1998-2017 OUTDOOR SITES NETWORK all rights reserved USA and Worldwide