Main Menu
Advertisement
Affiliates
Advertisement
Newest Members
liprippen, C. Walker, ronws67, Leftridge, Panhandleag18
102710 Registered Users
Top Posters
TexDawg 82858
hopalong 74380
Pilothawk 73417
JDavis7873® 67377
FattyMcButterpants 60518
John175 ® 59868
Tritonman 56822
Derek 56400
SkeeterRonnie 52453
LoneStarSon® 52212
facebook
Forum Stats
102710 Members
61 Forums
858858 Topics
11266872 Posts

Max Online: 36273 @ 01/23/13 02:34 PM
Topic Options
#10049394 - 06/09/14 12:00 PM locking system not working
bassdoode Offline
Pro Angler

Registered: 02/06/12
Posts: 593
the locking system on my fx 21 won't unlock? I can hear it lock but it won't try to unlock, the blinking security light just turns off. any suggestions on what the problem is? im thinking it is a blown fuse but im not sure. if so where is the fuse box located??

Top
#10049405 - 06/09/14 12:05 PM Re: locking system not working [Re: bassdoode]
fouzman Offline
Methuselah

Registered: 01/20/09
Posts: 43064
Loc: Houston, TX
Let me know what you find out. I've had heck with the alarm system on my '14 FX21. But my problem is the opposite of yours. My alarm won't turn off. So I just disconnected the red wire that runs to the speaker under the dash until I can get the boat to FnS for a fix. And we're not the only two, trust me.
_________________________
"Things turn out best for those who make the best of the way things turn out" - Zachary Troy Schrah - a young man with vision far beyond his years.

Top
#10049427 - 06/09/14 12:10 PM Re: locking system not working [Re: bassdoode]
Chris Borden Offline
TFF Team Angler

Registered: 03/23/10
Posts: 4963
Loc: Granbury
Mine is also a pita. Power,security code,power.If one of my lids isn't properly latched it just turns itself off. Then I have to go to each box and open and close them again and start the process all over until I finally get it locked.

Top
#10049442 - 06/09/14 12:14 PM Re: locking system not working [Re: bassdoode]
921 Phoenix Offline
Extreme Angler

Registered: 06/21/11
Posts: 1819
Loc: Lake Fork
I don't know if this will help. I had one of the first I20 2006 models. The locking system back then work like this. You had to put power to the locks to unlock, so when the power or batteries run down it would engage the locks. I found that if the battery ran down the locks would engage. Their may be a grounding wire that is getting lose and locking your locks because when they lose power is when they lock. You have to put power to them to disengage the locks. This was my experience back then. I came out several times to fine boxes lock and battery dead I would have to unlock with key to charge battery back up to get the locking system working again.

Top
#10049468 - 06/09/14 12:20 PM Re: locking system not working [Re: bassdoode]
fouzman Offline
Methuselah

Registered: 01/20/09
Posts: 43064
Loc: Houston, TX
I think this is an entirely new system for 2014. I had an '08 i-Class and never had such problems, but I know a bunch of folks who are having problems with the 2014's.
_________________________
"Things turn out best for those who make the best of the way things turn out" - Zachary Troy Schrah - a young man with vision far beyond his years.

Top
#10049515 - 06/09/14 12:34 PM Re: locking system not working [Re: bassdoode]
921 Phoenix Offline
Extreme Angler

Registered: 06/21/11
Posts: 1819
Loc: Lake Fork
I was just trying to help I know they change it up after the 06 because it was so bad. They even had a Pro that took a crow bar to his boxes because they locked and wouldn't unlock. The 06 had a real bad problem with locking just driving across the lake. I was just noting that it was the grounding or lack of that was causing the problem in that model. You very well maybe right that this is not the same but sure has a lot of similarity from what y'all are saying. This was the problem the 06 would lock and not unlock.

Top
#10049541 - 06/09/14 12:42 PM Re: locking system not working [Re: bassdoode]
921 Phoenix Offline
Extreme Angler

Registered: 06/21/11
Posts: 1819
Loc: Lake Fork
here is just one of many links to the problems for years with the locks. I didn't see it as a big problem to me because I never had the boat in a place to worry about getting stuff stole



http://www.bbcboards.net/skeeter-boats/81843-2009-iclass-auto-compartment-lock-system-problem.html

Top
#10052101 - 06/10/14 09:55 AM Re: locking system not working [Re: bassdoode]
921 Phoenix Offline
Extreme Angler

Registered: 06/21/11
Posts: 1819
Loc: Lake Fork
I just talked to the service guy at Fun N sun he said they do not have a known problem on the 2014 FX as far as the locking/alarm goes and as far as they know at this time. He said if he had to guess it is a wiring problem but it was not something that could be fixed over the phone. He said you will have to bring your boats in for them to look at. He said if their had been a problem he would have been glad to just let everyone know. This will most likely be a different problem on each boat.

Top
#10052127 - 06/10/14 10:04 AM Re: locking system not working [Re: bassdoode]
fouzman Offline
Methuselah

Registered: 01/20/09
Posts: 43064
Loc: Houston, TX
Dunno who you talked to, but one of the guys at FnS had precisely the same problem with his alarm system. He suggested I disconnect the wire to the speaker until I could get the boat to them. Not a knock on FnS nor Skeeter. I've not had time to get mine to the shop but it is a known problem. I know four other people with 14 FX's who also have this issue. I think it's in the computer of the electronics of the alarm system.

Again, FnS immediately offered to repair or replace mine when I bring it to them, right up front. They also told me how to silence the problem until that time. This isn't a FnS issue and I don't believe the issue will be a different problem on each boat.
_________________________
"Things turn out best for those who make the best of the way things turn out" - Zachary Troy Schrah - a young man with vision far beyond his years.

Top
#11337252 - 01/10/16 08:03 PM Re: locking system not working [Re: bassdoode]
Hog Caller Offline
Angler

Registered: 05/03/07
Posts: 373
Loc: san antonio, tx
I'm having the same problems and the dealer told me i was sh@i out of luck and they then took the module out. They said skeeter has no option for u, which is [censored] because we paid for products that work and sounds like we will just be stuck eating the upgrade money for it.Has anyone else heard of this???


2014 fx21

Top
#11337354 - 01/10/16 08:52 PM Re: locking system not working [Re: bassdoode]
COHLMEYER Offline
TFF Team Angler

Registered: 10/21/08
Posts: 3729
Loc: Weatherford, TX
They did away with them on the '15s. They figured out they should not be in the alarm business.

Top



© 1998-2016 OUTDOOR SITES NETWORK all rights reserved USA and Worldwide